Bug Hunting Session
Bug 52526 - Provide separate background colour (shading) for fields and formatting marks e.g., non-breaking hyphen
Summary: Provide separate background colour (shading) for fields and formatting marks ...
Status: RESOLVED DUPLICATE of bug 58434
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-26 09:35 UTC by Harald Koester
Modified: 2014-06-13 18:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2012-07-26 09:35:04 UTC
Problem description: 

Steps to reproduce:

[1] Open new text document.
[2] Choose a "nice" colour for the background of fields (Tools > Options > LibreOffice > Appearance > Custom Colors > Field shadings)
[3] Insert Formatting Marks: Menu > Insert > Formatting Marks. The background of inserted marks are displayed in the colour of fields.

Expected behaviour: Background of formatting marks should not be displayed in the colour of fields.

Comment: You can argue, that formatting marks are also a kind of fields. But fields are used for data which can change. This is not the case for formatting marks. Hence to my opinion this is a bug.              

Browser: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Harald Koester 2012-07-26 10:01:37 UTC
See also bug 52525 and bug 52527.
Comment 2 A (Andy) 2013-02-16 14:21:53 UTC
not reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

Do you still have this behavior/issue with the latest release of LO?  If not, then I would propose to mark it as Resolved.
Comment 3 Harald Koester 2013-02-16 21:48:41 UTC
For me it's still reproducible with Version 4.0.0.3 under Win 7 Prof, 32 bit.
Comment 4 Owen Genat (retired) 2013-11-22 04:20:16 UTC
(In reply to comment #0)
> Comment: You can argue, that formatting marks are also a kind of fields. But
> fields are used for data which can change. This is not the case for
> formatting marks. Hence to my opinion this is a bug.              

I agree that this would be a useful enhancement. Status set to NEW. Severity set to enhancement as this has never existed. Version set to Inherited From OOo.[1] Summary edited for greater clarity. 

[1] I have tested the appearance of formatting marks and fields under Crunchbang 11 x86_64 running:

- v3.3.0.4 OOO330m19 Build: 6
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

They always display using the same shading, as indicated in the description.
Comment 5 Harald Koester 2013-11-24 17:36:48 UTC
Hi Owen,
indeed a separate colour for formatting marks would be an enhancement. That would be fine, but that is not what I intended with my initial bug report. IMHO it's still a bug and I only expect that the normal document background colour is used for formatting marks. That would also be equal how Calc or Draw display formatting marks. But nevertheless I think this behaviour is only a minor problem and can be solved some day in future.
Comment 6 Owen Genat (retired) 2014-01-06 10:10:17 UTC
Setting version back from "Inherited From OOo" to what it was prior (for bugs marked enhancement), for QA tracking purposes. My mistake. Apologies.
Comment 7 Simo Kaupinmäki 2014-06-13 18:08:36 UTC

*** This bug has been marked as a duplicate of bug 58434 ***