Bug Hunting Session
Bug 52596 - FORMATTING Empty page inserted when Writer tables reach lower page border
Summary: FORMATTING Empty page inserted when Writer tables reach lower page border
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Writer-Tables-Enhancements
  Show dependency treegraph
 
Reported: 2012-07-27 18:34 UTC by fisselspinne
Modified: 2019-01-21 10:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing problem as described (91.19 KB, image/jpeg)
2012-07-27 18:34 UTC, fisselspinne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fisselspinne 2012-07-27 18:34:43 UTC
Created attachment 64797 [details]
Screenshot showing problem as described

Problem description: When a table made in Writer reaches down to the border, a new page will be created, even at the end of a document, when no further content is to follow; that page cannot be removed. No major issue, but looks stupid.

The problem is that Writer creates a new line under each table, of course in your chosen font and size. When it won't  fit under the table, it will go to a new page. Seems logic, but if there's nothing more to come you won't need a new page.
Workaround: setting font size of the empty line to 1 will usually make it small enough, so that the page goes away.

Steps to reproduce:
1. Insert a table to Writer that fills the whole page
2. In my case footers were enabled, don't know if they are needed to reproduce
3. Get a new page (see attachment), try to remove it -> won't go away

Expected behavior: New page created only when new content begins

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.11 (KHTML, like Gecko) Chrome/20.0.1132.57 Safari/536.11

Greetings,
Caroline
Comment 1 A (Andy) 2013-02-16 14:40:44 UTC
I agree and I also have already experienced this problem in my daily work.  It would be good to have a solution for this.
-> reproducible with LO 4.0.0.3 (Win7 Home, 64bit), it also does not depend on inserting a footnote
Comment 2 QA Administrators 2015-02-19 15:49:52 UTC Comment hidden (obsolete)
Comment 3 A (Andy) 2015-02-20 20:07:24 UTC
Reproducible with LO 4.4.0.3, Win 8.1
Comment 4 Cor Nouws 2015-12-18 11:40:19 UTC
Behind the screen, this is a basic design issue: Tables are in a different context in Writer. So I guess therefor always a paragraph after a table is present..