Bug Hunting Session
Bug 53002 - : Turkish Default Currency to be changed YTL to TL
Summary: : Turkish Default Currency to be changed YTL to TL
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: low enhancement
Assignee: Efe Gürkan YALAMAN
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-31 13:12 UTC by Zeki Bildirici
Modified: 2013-03-05 15:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example list in Calc's Cell Formatting dialog (145.94 KB, image/jpeg)
2012-07-31 13:12 UTC, Zeki Bildirici
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zeki Bildirici 2012-07-31 13:12:32 UTC
Created attachment 64989 [details]
Example list in Calc's Cell Formatting dialog

Problem description: 

Turkish currency New Turkish Lira was replaced with Turkish Lira on 01.01.2009.

However, LibreOffice(and the former Openoffice.org)has the Turkish Currency as YTL(New Turkish Lira) which is now obsolete.

The currencies for Turkish are:

TRL TL  Türkçe (Used until 2005)
TRY YTL Türkçe (Used until 2009)

But now, the currency is:

TRY TL Türkçe

Also the currency sign added to Turkish lira: http://en.wikipedia.org/wiki/Turkish_lira But it will  be a bit difficult to implement this sign to LibreOffice i think.

Thus, the default currency for Turkish should be:
TRY TL Türkçe

Note: This may be an easyhack i think.

Regards,
Zeki,
Comment 1 Joel Madero 2012-08-02 20:59:28 UTC
Confirmed in 3.7.0.0.alpha0+ (Build ID: b806b63). I'll take care of this. Thanks for reporting!
Comment 2 Joel Madero 2012-08-02 21:02:02 UTC
Nevermind it looks like it's already being looked into. Assigning it to the appropriate person
Comment 3 Efe Gürkan YALAMAN 2012-08-02 21:18:03 UTC
I sent patch to Developers list.

Currency sign is not implemented yet.

http://www.tcmb.gov.tr/yeni/iletisimgm/TurkishLira.php
Comment 4 Joel Madero 2012-08-02 21:27:00 UTC
Thanks for the update. Once it has been accepted and implemented in master could you mark as RESOLVED.
Comment 5 Efe Gürkan YALAMAN 2012-08-02 21:29:47 UTC
done.
Comment 6 Joel Madero 2012-08-02 21:31:20 UTC
If it hasn't been accepted into master branch then it's not resolved. Has it been accepted?
Comment 7 Efe Gürkan YALAMAN 2012-08-02 21:36:53 UTC
(In reply to comment #6)
> If it hasn't been accepted into master branch then it's not resolved. Has it
> been accepted?

http://lists.freedesktop.org/archives/libreoffice/2012-August/036165.html

I am not sure after that question. Is this mail means it is accepted? :)
Comment 8 Joel Madero 2012-08-02 21:41:27 UTC
I didn't see the pushed, yes you're correct. Thanks for correcting me. 

This has been fixed in master.
Comment 9 Joel Madero 2012-08-07 19:49:36 UTC
my mistake, thanks for doing this! any word or progress on getting the symbol in there?
Comment 10 Efe Gürkan YALAMAN 2012-08-08 07:20:05 UTC
http://www.tcmb.gov.tr/yeni/iletisimgm/TurkishLira.php

Currency sign is in JPG format. I didn't tried yet.
Comment 11 Adolfo Jayme 2013-03-05 15:58:59 UTC
Hi, just a heads-up. The new Turkish Lira symbol (₺) has been implemented in LibreOffice, see bug 61602 for details.