Bug Hunting Session
Bug 53049 - Recorded Macro not available after update
Summary: Recorded Macro not available after update
Status: RESOLVED DUPLICATE of bug 52022
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-01 15:48 UTC by vimot2
Modified: 2012-08-02 04:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vimot2 2012-08-01 15:48:01 UTC
Problem description: a macro recorded and then assigned to a Menu item, does not work after a program update. This is the second occurrence in the past three month updates.

Steps to reproduce: N/A
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

Platform (if different from the browser): Ubuntu 12.04
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Rainer Bielefeld Retired 2012-08-01 17:31:42 UTC
Does not work is no useful description. Macro does not exist? Keyboard shortcut broken? Seems to work, but result is not as expected? Or what else?

Not a valid bug report!

@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- If that can help to explain the bug, please attach a sample document 
  (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link; to attach a file to this 
  bug report, just click on "Add an attachment" right on this page.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a document related step by step instruction containing every 
  key press and every mouse click how to reproduce your problem 
  (similar to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS (Language)
  -- concerning the LibO version from what you updated
  -- All related details how you updated
  –- Libo settings that might be related to your problems 
  -- everything else crossing your mind after you read linked texts
Comment 2 vimot2 2012-08-01 18:45:11 UTC
(In reply to comment #1)
> Does not work is no useful description. Macro does not exist? Keyboard shortcut
> broken? Seems to work, but result is not as expected? Or what else?
> 
> Not a valid bug report!
> 
> @reporter:
> Thank you for your report – unfortunately important information is missing.
> May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to
> find out what information will be useful to reproduce your problem? If you
> believe that that  is really sophisticated please as for Help on a user mailing
> list
> Please:
> - Write a meaningful Summary describing exactly what the problem is
> - If that can help to explain the bug, please attach a sample document 
>   (not only screenshot) or refer to an existing 
>   sample document in an other Bug with a link; to attach a file to this 
>   bug report, just click on "Add an attachment" right on this page.
> - Attach screenshots with comments if you believe that that might explain the 
>   problem better than a text comment. Best way is to insert your screenshots
>   into a DRAW document and to add comments that explain what you want to show
> - Contribute a document related step by step instruction containing every 
>   key press and every mouse click how to reproduce your problem 
>   (similar to example in Bug 43431)
> – if possible contribute an instruction how to create a sample document 
>   from the scratch
> - add information 
>   -- what EXACTLY is unexpected
>   -- and WHY do you believe it's unexpected (cite Help or Documentation!)
>   -- concerning your PC 
>   -- concerning your OS (Language)
>   -- concerning the LibO version from what you updated
>   -- All related details how you updated
>   –- Libo settings that might be related to your problems 
>   -- everything else crossing your mind after you read linked texts

Sorry. I will try to be more precise. I recorded a simple macro to paste a block of data simply as number. Then I associate this macro to a new menu item.
All was working for a couple of months. After a program update, after clicking on the menu item, I received an error of macro not found (or something like that). The macro disappeared from the macro list.
I repeated the procedure creating a new macro. Same as above: after some time, I found that the macro disappeared again.
Unfortunately I have not recorded the error message. Next time I will do if the issue comes again. I am not sure that the issue is caused by program updates or something else. (sorry for my English, I am italian).
Comment 3 Rainer Bielefeld Retired 2012-08-02 04:56:21 UTC
Unfortunately still all relevant information is missing, so I close this bug for now as DUP of "Bug 52022 - CONFIGURATION: 'My Macros' lost after update from 3.5.5.3".

I will soon do further tests there, because currently information there also is rather poor.

@vimot2:
There is no need to cite all comment. Please use Bugzilla frontend (not mail client) for your comments and only if necessary and only parts of former comments.

I only have experience with WIN but I believe on Linux it will be very similar. I use the default "Folder" "My Macros" in the User Profile
<https://wiki.documentfoundation.org/UserProfile#User_profile_location>
under .... \LibreOffice\3\user\basic\Standard\ in a file called "MyMacros.xba" (or similar). With a text editor you can see the source code.

Now the question is whether the .xba disappeared or has been destroyed or whether your profile folder changed or whatever?

You can get assistance on
<http://ask.libreoffice.org/questions/>
or on the public users mailing list <users@libreoffice.org>, a mailing list from <http://www.documentfoundation.org/contribution/#lists> or
<http://wiki.documentfoundation.org/Local_Mailing_Lists>

Please feel free to reopen this Bug if discussion with others leaded to an assessment that we have a LibO bug and a clear and comprehensible description of the problem due to  <http://wiki.documentfoundation.org/BugReport>.

*** This bug has been marked as a duplicate of bug 52022 ***