Bug Hunting Session
Bug 53051 - Right-click on LO symbol in OS X Dock shows all recently opened documents
Summary: Right-click on LO symbol in OS X Dock shows all recently opened documents
Status: CLOSED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-01 16:14 UTC by Johannes Weberhofer
Modified: 2012-10-12 14:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot - how the popup menu look in LibO 3.6.2.1 on Mac OS X 10.6.8 (386.41 KB, image/png)
2012-09-25 12:04 UTC, Roman Eisele
Details
LO Icon/menu having no documents opened (just started) (361.67 KB, image/png)
2012-09-25 12:26 UTC, Johannes Weberhofer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Weberhofer 2012-08-01 16:14:21 UTC
With the new version all recently opened files are displayed but without path-names. In older versions only the open files where shown - which I prefered. I can live with that in case it's a feature not a bug :-)
Comment 1 Roman Eisele 2012-09-16 07:57:57 UTC
Not yet confirmed, therefore reset Status.
Comment 2 Roman Eisele 2012-09-25 12:03:01 UTC
Thank you very much for your bug report!

However, as far as I can see LibreOffice 3.6.2.1 on Mac OS X 10.6.8 show *both* lists if I right-click (control-click) on the LibreOffice symbol in the Dock:
* at the top of the first section of the popup menu, a list of all open files
  (only the file name and the LibreOffice component, e.g. “LibreOffice Writer”,
  without the full path);
* in the sub-menu “File > Recently used documents > …”, a list of all
  recently opened files, with (parts of) the file path.
I will attach a screenshot showing this.

So my question is: do you see the same (and then, what’s wrong with that), or do you see something else (and then, a screenshot(*) would be very helpful)?

Thank you very much!


(*) You can take a screenshot of a menu if you start Apple’s utility (Dienstprogramm) “Bildschirmfoto” and use the function “Selbstauslöser” from the menu “Foto”.
Comment 3 Roman Eisele 2012-09-25 12:04:40 UTC
Created attachment 67678 [details]
Screenshot - how the popup menu look in LibO 3.6.2.1 on Mac OS X 10.6.8



The screenshot shows how the popup menu look in LibO 3.6.2.1 on Mac OS X 10.6.8.
Comment 4 Roman Eisele 2012-09-25 12:05:45 UTC
Comment on attachment 67678 [details]
Screenshot - how the popup menu look in LibO 3.6.2.1 on Mac OS X 10.6.8

Fix MIME type
Comment 5 Johannes Weberhofer 2012-09-25 12:25:00 UTC
Thank you for adding the screenshots. The List at the top (opened documents) contains a list of documents, which are not the opened documents. I'll attach another screenshot. I can't imagine, how this list is created.
Comment 6 Johannes Weberhofer 2012-09-25 12:26:08 UTC
Created attachment 67682 [details]
LO Icon/menu having no documents opened (just started)
Comment 7 Roman Eisele 2012-09-25 17:58:43 UTC
(In reply to comment #5)
> Thank you for adding the screenshots. The List at the top (opened documents)
> contains a list of documents, which are not the opened documents. I'll
> attach another screenshot. I can't imagine, how this list is created.

Wow -- thank you for the screenshot! This makes it clearer. So in the place where I see (correctly) a list of open documents (if any), you see a strange list of documents, maybe some mixup of documents recently opened ...

We must find out what’s the reason for this behaviour.

Just three ideas to check:
1) I am not aware that there was a bug fixed about that in the last versions,
   but if you still use LibO 3.6.0.4 you may want to update anyway
   to 3.6.1.2 or, even better, directly to 3.6.2.1 (available from
     http://www.libreoffice.org/download/pre-releases/
   ; this version is called a “pre-release”, but in my experience it runs
   a whole lot better than 3.6.0.4 or 3.6.1.2).
   Does this make a difference? Probably not, but we should check this ...
  
2) Maybe there is some corruption in your list of recently opened documents
  (there was/were a/some bugs in previous LibO versions related to this
  file!). To check, please quit LibreOffice (if running) and then
  delete or remove the following two files:
     org.libreoffice.script.LSSharedFileList.plist
     org.libreoffice.script.plist
  from the folder:
     <Your hard drive>/Users/<your user name>/Library/Preferences/
  and then try again if this changes the behaviour.

3) Another possibility is that there is some corruption of the general
   application settings. Can you please try to reset your LibreOffice user
   profile folder (temporarily)? To do so, please:
   a) Quit LibreOffice (if running).
   b) Open the following folder on your main hard drive:
      <Your hard drive>/Users/<your user name>/Library/Application Support/
      This folder contains a folder named “LibreOffice”; this is your
      LibreOffice user profile folder, containing most settings.
   c) Please rename this folder to something else, e.g. “LibreOffice-old”.
   d) Start LibreOffice again (it will create a new user profile folder
      with default settings, so this startup takes longer than usual).
   e) Please try now if you can still reproduce the issue.

Please report the answers/the results of your tests here.

Thank you very much!
Comment 8 Johannes Weberhofer 2012-09-25 20:07:58 UTC
Dear Roman, I'm actually using "Version 3.6.2.1 (Build ID: ba822cc)". None of your suggestions helped, but digging a little bit deeper into the problem was quite interesting:

I think, there must be a new feature included in OSX 10.8, which makes the opened files displayed directly via the OS. This seems to be true, as I've recognized, that the list is always visible, even when I exit LO. The list behaviour is a little bit strange, as the latest opened file is always displayed at the end of the list (I would expect it at the top of the list).

In case, that is all controlled by OSX, it could be good, to remove the Symbol's "File"->"Resenly used Docs" from the Menu and offer only one Menu to the user for OSX>=10.8...
Comment 9 Roman Eisele 2012-09-26 08:02:07 UTC
> I think, there must be a new feature included in OSX 10.8, which makes the
> opened files displayed directly via the OS. This seems to be true, as I've
> recognized, that the list is always visible, even when I exit LO. The list
> behaviour is a little bit strange, as the latest opened file is always
> displayed at the end of the list (I would expect it at the top of the list).

Do other applications (I mean, if you right-click on the symbol of another application in the Dock) show the same files list? This would confirm that the new behaviour is a new OS X 10.8 feature.

> In case, that is all controlled by OSX, it could be good, to remove the
> Symbol's "File"->"Resenly used Docs" from the Menu and offer only one Menu
> to the user for OSX>=10.8...

This may be more difficult as it seems, because I assume that the code which builds that menu is the same which is used to assemble the normal “File” menu of LibreOffice when no window at all is open. But this would be a little improvement, right.
Comment 10 Johannes Weberhofer 2012-09-28 05:15:57 UTC
(In reply to comment #9)
> > I think, there must be a new feature included in OSX 10.8, which makes the
> > opened files displayed directly via the OS. This seems to be true, as I've
> > recognized, that the list is always visible, even when I exit LO. The list
> > behaviour is a little bit strange, as the latest opened file is always
> > displayed at the end of the list (I would expect it at the top of the list).
> 
> Do other applications (I mean, if you right-click on the symbol of another
> application in the Dock) show the same files list? This would confirm that
> the new behaviour is a new OS X 10.8 feature.

When I copy the "TextEdit.app" into the Launchpad, I see the list of recently opened docs also when the app is closed. Did this change compared to the version, you are using?

> 
> > In case, that is all controlled by OSX, it could be good, to remove the
> > Symbol's "File"->"Resenly used Docs" from the Menu and offer only one Menu
> > to the user for OSX>=10.8...
> 
> This may be more difficult as it seems, because I assume that the code which
> builds that menu is the same which is used to assemble the normal “File”
> menu of LibreOffice when no window at all is open. But this would be a
> little improvement, right.

Ok. It's not that important. It's just a little bit confusing.
Comment 11 Roman Eisele 2012-09-28 15:23:10 UTC
(In reply to comment #10)
> > Do other applications (I mean, if you right-click on the symbol of another
> > application in the Dock) show the same files list? This would confirm that
> > the new behaviour is a new OS X 10.8 feature.
> 
> When I copy the "TextEdit.app" into the Launchpad, I see the list of
> recently opened docs also when the app is closed. Did this change compared
> to the version, you are using?

Yes, it did change. On Mac OS X 10.6.8, when you right-click any application icon in the dock, the menu shows only the *open* files; and when the app is closed, no documents are listed at all. So this is really a Mac OS feature.

→ Therefore I propose to close this bug report as RESOLVED/NOTABUG or, if you don’t like the new behaviour, as RESOLVED/NOTOURBUG ;-)


> > > In case, that is all controlled by OSX, it could be good, to remove the
> > > Symbol's "File"->"Resenly used Docs" from the Menu and offer only one Menu
> > > to the user for OSX>=10.8...
> > 
> > This may be more difficult as it seems […]
> >
> Ok. It's not that important. It's just a little bit confusing.

You are right, it is a bit confusing. So please file a new bug report (I suggest a new one, to get a short and clean description; using the present bug report would be IMHO a bit confusing), set the Importance field to “Enhancement” (because I would say it is rather an enhancement than a bug) or “minor” (if you consider this as a bug), and explain in clear words that on Mac OS X >= 10.8 there is now this menu of recently opened items, and that therefore LibreOffice’ own sub-menu "File"->"Resenly used Docs" should be removed from the menu if on Mac OS OS X >= 10.8.

Thank you very much for this! Please CC me about the new report, and I will confirm it immediately.
Comment 12 Johannes Weberhofer 2012-10-12 14:04:21 UTC
Have filed an enhancement-ticket in #55922
Comment 13 Roman Eisele 2012-10-12 14:25:28 UTC
(In reply to comment #12)
> Have filed an enhancement-ticket in #55922

Thank you! So I think we can close the present bug report, because the remaining issue is handled in bug 55922?!
Comment 14 Johannes Weberhofer 2012-10-12 14:52:35 UTC
Thank you, too. I've closed the bug.