Bug 53107 - Insert Comment missing after .XLS save and file re-opened
Summary: Insert Comment missing after .XLS save and file re-opened
Status: RESOLVED DUPLICATE of bug 52998
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-03 21:22 UTC by NoJoy
Modified: 2012-08-04 18:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Insert Comment using LO Calc v3.5.4.2, viewable by v3.6.0.4 (RC) (6.50 KB, application/vnd.ms-excel)
2012-08-03 22:45 UTC, NoJoy
Details
Insert Comment using LO Calc v3.6.0.4, not viewable by v3.6.0.4 (5.50 KB, application/vnd.ms-excel)
2012-08-03 23:10 UTC, NoJoy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NoJoy 2012-08-03 21:22:23 UTC
Steps to reproduce issue:

1. Open LO Calc v3.6.0.4 (RC)
2. Insert any value into cell A1 (eg 123)
3. Right Click, then select Insert Comment
4, Add any text into Comment box, close box
5. Verify comment is marked in upper right of A1 cell, and comment appears with mouse hover over
6. Save file using Save As TEST.XLS (MS Excel 97/2000/XP/2003 XLS)
7. Using LO Calc, open TEST.XLS and the comment in cell A1 has been removed/deleted

Thank you for the follow up.
Comment 1 NoJoy 2012-08-03 22:45:22 UTC
Created attachment 65104 [details]
Insert Comment using LO Calc v3.5.4.2, viewable by v3.6.0.4 (RC)
Comment 2 NoJoy 2012-08-03 23:10:28 UTC
Created attachment 65105 [details]
Insert Comment using LO Calc v3.6.0.4, not viewable by v3.6.0.4
Comment 3 NoJoy 2012-08-03 23:12:50 UTC
Another bug clue ---

Using LO Calc 3.5.4.2, when I insert a comment, I can successfully save it and then view it using Calc v3.6.0.4 without issue.

Using Calc v3.6.0.4 as the creator of the file, when I insert a comment, save the file and reopen the file, this does not work. The inserted comments are lost whenever the file is saved/reopened.

Please see attached, and it appears that the Save As "MS Excel 97/2000/XP/2003 XLS" function in Calc v3.6.0.4 is not working properly.

Thanks again for the follow up.
Comment 4 Jean-Baptiste Faure 2012-08-04 18:24:46 UTC
duplicate of bug 52998

*** This bug has been marked as a duplicate of bug 52998 ***