Bug Hunting Session
Bug 53126 - VIEWING: Base scrolling malfunctioning
Summary: VIEWING: Base scrolling malfunctioning
Status: CLOSED DUPLICATE of bug 51239
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-04 16:47 UTC by narea92
Modified: 2012-11-18 18:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Confirming Bug with Mint 13 Mate also (44.39 KB, application/vnd.oasis.opendocument.base)
2012-11-18 15:56 UTC, narea92
Details

Note You need to log in before you can comment on or make changes to this bug.
Description narea92 2012-08-04 16:47:42 UTC
Problem description: 

Steps to reproduce:
1  Base opened. ....
2. Display....
3. ....

Current behavior:up scrolling all the display changes to one record only 

Expected behavior:scrolling the records  

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 narea92 2012-08-04 22:41:37 UTC
Fortunately, if I close without saving when I reload no data are lost.
Comment 2 Robert Großkopf 2012-08-05 14:39:17 UTC
Could be it's the same problem as reported here:
https://bugs.freedesktop.org/show_bug.cgi?id=51239
Do you get this behaviour with a normally table in Base? The steps you describe don't say anything about this. When I will reproduce this, it isn't differenciated enough. When I open Base I only see the folder forms. What shall be "Display"??
The behaviour you reported could have something to do with the cache of the table, through which you scroll - or isn't it a table? 
How many rows does the table/query have?
Is it a query, which links tables?
A screenshot of rows with the same content incl. the primary-key could show the behaviour to other users.
Comment 3 Jochen 2012-08-30 06:41:38 UTC
@reporter

we need further information
1) Can you reproduce the malfunction still?
2) Have a look a comment 2 and answer the questions
3) Describe the single steps in detail - e.g. "Base opened" and "display" is not informative to reproduce.
Comment 4 narea92 2012-11-18 15:56:57 UTC
Created attachment 70219 [details]
Confirming Bug with Mint 13 Mate also

I am experiencing the same bug with Linux Mint 13 Mate.
The only additional informations that I am capable to give to you are:
The Base is a database created with the wizard.
The Disply is the the disply of the saved records when I open the Base file.
Yours,
Gaetano Arena
Comment 5 Alex Thurgood 2012-11-18 18:36:15 UTC
Confirming, but it is a DUP of 51239, which has been fixed in master, 3.6.x and backported to 3.5.6 and 3.5.7. The problem for the user is that Linux Mint 13 does not offer any of those versions so he/she will have to download and install frol the official LO site.

@Gaetano : the version that comes with Mint 13 was taken from the Ubuntu repos and it is a heap of ...., get yourself a more recent version from the LO download site and install that instead until the Mint people can get their act together and provide something more recent (maybe you can from the Software Repository online, I haven't looked lately).

Closing as DUP

Alex
Comment 6 Alex Thurgood 2012-11-18 18:36:32 UTC

*** This bug has been marked as a duplicate of bug 51239 ***