Bug 53151 - UI: the drag cursor (hand) is inconvenient
Summary: UI: the drag cursor (hand) is inconvenient
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: low enhancement
Assignee: Rimas Kudelis
QA Contact:
URL:
Whiteboard: target:4.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-06 06:37 UTC by Rimas Kudelis
Modified: 2015-05-21 16:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (31.36 KB, image/png)
2012-08-06 06:37 UTC, Rimas Kudelis
Details
Quick fix: same hand cursor with its hotspot moved between fingers (326 bytes, image/x-icon)
2013-06-10 17:44 UTC, Rimas Kudelis
Details
Quick fix preview (15.67 KB, image/png)
2013-06-10 17:47 UTC, Rimas Kudelis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rimas Kudelis 2012-08-06 06:37:59 UTC
Created attachment 65150 [details]
Screenshot

When dragging the small yellow handles of callouts, a big and inconvenient hand cursor is being used. That cursor makes it hard to position the point accurately. Please check out the screenshot to see what I'm talking about.

I would suggest to either use a crosshair cursor, or some other cursor that would not get in the way.

This might be Windows-specific. I checked on Linux, and the cursor used was different there.
Comment 1 Hashem Masoud 2012-10-06 08:12:40 UTC
(In reply to comment #0)

> This might be Windows-specific. I checked on Linux, and the cursor used was
> different there.

Exactly. In Linux it's a 1-finger pointing hand. Can anyone having Windows please confirm?
Comment 2 QA Administrators 2013-05-29 23:05:05 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 3 Rimas Kudelis 2013-05-30 04:34:36 UTC
I still have the same hand in Windows with LibreOffice 4.0.3.3.

Considering that I've attached a screenshot here, do you really need someone else to confirm the bug?
Comment 4 Joel Madero 2013-05-30 04:43:18 UTC
Yes - it might be your environment, not our product. Marking as UNCONFIRMED
Comment 5 Joel Madero 2013-05-30 04:45:04 UTC
Obviously very unlikely your enviro. in this case ;) Sorry for the spam, but our workflow dictates that an independent triager confirm the issue and then we can get others involved that might be able to fix it. UX has to write off on this change so their input will be needed
Comment 6 Rimas Kudelis 2013-05-30 04:46:24 UTC
Fine, although if nobody cared enough to triage this in six months, what are the odds of somebody starting to care now?
Comment 7 Joel Madero 2013-05-30 04:51:06 UTC
Our team is quite small and we have thousands of bugs to triage, we are working as hard as we can I assure you. Our team is growing and you could be a part of it and join and see how much work it takes for us to do what we do. 

Just an idea, in February over 1,000 bugs were reported, the unconfirmed bug count actually dropped by 35 during the month - meaning our small team (just a few of us) triaged over 1,000 bugs. If you want to be a part of the solution (getting bugs triaged faster) instead of just say negative comments, we'd love to have you join us in our chat (#libreoffice-qa), our team is very friendly and very productive.

In this case - it's true, enhancements obviously get less priority then true bugs - just how it goes when we have 75 million users and less than 20 regular triagers
Comment 8 Joel Madero 2013-05-30 17:46:40 UTC
Probably quite easy to fix so code pointers appreciated - 

Confirmed
New
Enhancement
Low - reality is this isn't impacting work very much and if it is, limited number of people affected - proof being that there is only one person (the reporter) who has reported/discussed the issue in almost a year, no duplicate bugs, no other comments.

Thanks for reporting and for being patient with getting it confirmed.

CC'ing Astron as well - Astron thoughts on this? You want to bring it up at UX meeting or just confirm that we can go through with a fix
Comment 9 Stefan Knorr (astron) 2013-06-04 16:48:50 UTC
Hi all,

so, I believe there are some BMPs laying around somewhere for these cursors. Probably since no one wrote code to use BMP cursors on Linux/Mac, we use native cursors there ...
So for one, these cursors look very 90's, and for the other, they don't really match the Windows theme and of course there is the aforementioned usability issue that you don't see what you drag ... they should be replaced.

The problem is, to me, it is not completely clear what to replace them with. The hand that is visible on Linux usually signifies a hyperlink, which the dragging point certainly isn't.
I guess using the system default for cross-hairs might be the best option.
Comment 10 Joel Madero 2013-06-05 18:08:55 UTC
Astron - I think the cross hair is a great idea, it's intuitive and won't get in the way (as long as it's not massive like the hand is). Is this relatively easy to fix?
Comment 11 Rimas Kudelis 2013-06-08 20:20:03 UTC
This week I checked what cursor is used on Linux, and yeah, it uses the pointer, which is usually associated with a link. I think crosshair would fit better on Linux as well, however, for some strange reasons, at least on my Debian Linux installation, the crosshair cursor is just as inconvenient as the BMP hand on Windows... The problem is that it overlays the center badly, thus making it impossible to see what's behind, thus making it harder to position whatever you are positioning precisely. However, I found a "target" cursor on Linux which could probably be used here.

So, I guess what I want to say is if/when someone decides to fix this problem on Windows, they could as well do it on Linux at the same time.
Comment 12 Stefan Knorr (astron) 2013-06-10 08:04:38 UTC
(In reply to comment #11)
> This week I checked what cursor is used on Linux, and yeah, it uses the
> I think crosshair would
> fit better on Linux as well, however, for some strange reasons, at least on
> my Debian Linux installation, the crosshair cursor is just as inconvenient
> as the BMP hand on Windows... The problem is that it overlays the center
> badly, thus making it impossible to see what's behind, thus making it harder
> to position whatever you are positioning precisely.

Hm, but you still have the benefit that you know exactly where the centre of a crosshair is. Unlike with the Windows-specific hand, where the the centre was not actually in the area that the shape of the hand was suggesting was grabbing, i.e. the free space between the thumb and the pointing finger, but somewhere in the opaque part of the hand.
(Which makes me think – is the hand actually unfixable? If we rectified the position of its centre point, and replaced the image... The problem would be mostly that we'd have to do at least four cursor styles: Windows, OS X, DMZ & Whiteglass for Linux. And we would have to switch this every so often as OS's switch to new cursor themes.)

 
> So, I guess what I want to say is if/when someone decides to fix this
> problem on Windows, they could as well do it on Linux at the same time.

Indeed. And on Mac, too (I don't know the exact situation there, but I assume it is the same as on Linux).


(PS: Rimas, sorry for claiming your idea with the crosshair pointer as mine in the previous post… not sure how I got to believe that.)
Comment 13 Rimas Kudelis 2013-06-10 16:12:32 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > This week I checked what cursor is used on Linux, and yeah, it uses the
> > I think crosshair would
> > fit better on Linux as well, however, for some strange reasons, at least on
> > my Debian Linux installation, the crosshair cursor is just as inconvenient
> > as the BMP hand on Windows... The problem is that it overlays the center
> > badly, thus making it impossible to see what's behind, thus making it harder
> > to position whatever you are positioning precisely.
> 
> Hm, but you still have the benefit that you know exactly where the centre of
> a crosshair is. Unlike with the Windows-specific hand, where the the centre
> was not actually in the area that the shape of the hand was suggesting was
> grabbing, i.e. the free space between the thumb and the pointing finger, but
> somewhere in the opaque part of the hand.
> (Which makes me think – is the hand actually unfixable? If we rectified the
> position of its centre point, and replaced the image... The problem would be
> mostly that we'd have to do at least four cursor styles: Windows, OS X, DMZ
> & Whiteglass for Linux. And we would have to switch this every so often as
> OS's switch to new cursor themes.)

I guess you're right, that could be fixed. And the Linux crosshair is not cast in stone either, it could be fixed upstream.

Either way, I believe that when a stock cursor is provided by the OS for some purpose, we should use that stock cursor. The crosshair cursor is provided exactly for the purpose of precise positioning, so it's sort of a shame that we resorted to 90'ish BMPs on Win and link pointer on Lin...

If only I knew at least the name of that BMP cursor, I would probably attempt grepping for it and maybe even providing a small patch... ;)

> (PS: Rimas, sorry for claiming your idea with the crosshair pointer as mine
> in the previous post… not sure how I got to believe that.)

No problem, I never thought you were claiming something.
Comment 14 Rimas Kudelis 2013-06-10 16:24:46 UTC
In fact, I just downloaded the source tarball, and found this work of art, it's here:

http://cgit.freedesktop.org/libreoffice/core/tree/vcl/win/source/src

Oh My God, we have soooo many ugly cursors and icons there. Someone has to do something! :)
Comment 15 Rimas Kudelis 2013-06-10 17:44:07 UTC
Created attachment 80631 [details]
Quick fix: same hand cursor with its hotspot moved between fingers

Here's a quick fix. Sorry, no patch, cause it's a binary file.

I have moved this cursors hotspot into a more appropriate position, between the thumb and other fingers.

It seems that the hand cursor is used for certain point operations, so I'll leave it up to developers or UX people to decide whether or not the crosshair fits there.

As a sidenote, it looks like salsrc.rc [1] and salframe.cxx [2] would benefit from some cleanup. The former still sets some cursors for windows versions below 4.0(=win98) and non-NT windows, which are all dead and unsupported now. Removing that code would allow to remove help.cur, hsize.cur, vsize.cur, neswsize.cur and nwsesize.cur. Furthermore, I found at least four cursors that have stock versions with IDC_ identifiers in Windows (cross.cur = IDC_CROSS, move.cur == IDC_SIZEALL, notallow.cur == IDC_NO, refhand.cur == IDC_HAND).

[1] http://cgit.freedesktop.org/libreoffice/core/tree/vcl/win/source/src/salsrc.rc
[2] http://cgit.freedesktop.org/libreoffice/core/tree/vcl/win/source/window/salframe.cxx#n2106
Comment 16 Rimas Kudelis 2013-06-10 17:47:53 UTC
Created attachment 80632 [details]
Quick fix preview

Here's a preview of what my previous attachment looks like. On the left, you see it at its natural size, and the dotted crosshair line indicates where the hotspot is. On the right, is its zoomed in version with the hotspot indicated by a small ball.
Comment 17 Joel Madero 2014-02-27 22:55:24 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 18 Rimas Kudelis 2015-01-07 17:23:05 UTC
I checked on Linux today, and on that platform, LibreOffice re-uses the hand with a pointing finger (aka link) cursor for hand.

Perhaps it would be acceptable to do the same on Windows as well?
Comment 19 Adolfo Jayme 2015-01-09 02:49:11 UTC
For the record: this was fixed in http://cgit.freedesktop.org/libreoffice/core/commit/?id=2abbc6fa577565376910a1b8e5e8931a2202e989

Thanks a lot, Rimas!
Comment 20 Mike §chinagl 2015-05-21 16:18:27 UTC
This bug fix is mentioned in the release notes of the coming LibreOffice 5.0 (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0). Therefore it would be wonderful if this feature really worked well, otherwise it should not be mentioned in the release notes. In the notes it reads:

    Many hardcoded cursors, drawn back in the StarOffice era to support now-obsolete Windows versions, were dropped in favor of native cursors, which have a more modern look. tdf#53148 tdf#53151 (Rimas Kudelis)