Download it now!
Bug 53221 - UI: Writer crashes when double click on styles or page preview
Summary: UI: Writer crashes when double click on styles or page preview
Status: RESOLVED DUPLICATE of bug 47368
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-07 19:48 UTC by Xavier
Modified: 2012-09-13 13:15 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Problem details shown by Mac OS "Problem report" window (127.03 KB, text/plain)
2012-08-07 19:48 UTC, Xavier
Details
Steps to reproduce (129.53 KB, image/png)
2012-08-07 19:55 UTC, Xavier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xavier 2012-08-07 19:48:29 UTC
Created attachment 65247 [details]
Problem details shown by Mac OS "Problem report" window

Problem description: The "LibreOffice Writer" application crashes when I double click on :
- One page in the page preview (not always)
OR
- One style in the styles list (paragraph styles, character styles, page styles, ...) (not always but always when the style has children)

Steps to reproduce:
1. Start LibreOffice Writer (tested on MacOS 10.6.8)
2. In the default "blank" document, show the panel that lists all the styles
3. Double click on a style that has children (with one gray arrow)

Current behavior: "libreOffice quit unexpectedly"

Expected behavior: the style is applied to the current element (paragraph, page, character, ...)

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_6_8) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.57 Safari/537.1
Comment 1 Xavier 2012-08-07 19:50:39 UTC
PS: This bug also affects OpenOffice Writer.
Comment 2 Xavier 2012-08-07 19:55:23 UTC
Created attachment 65248 [details]
Steps to reproduce
Comment 3 Julien Nabet 2012-08-07 19:57:56 UTC
Could you take a look at https://bugs.freedesktop.org/show_bug.cgi?id=47368 and
tell us if it could apply to your case ?
Comment 4 Xavier 2012-08-09 07:11:56 UTC
Yes, it is the same problem ! To disable accessibility on MacOS solves these bugs. Thank you.
Comment 5 Julien Nabet 2012-08-09 07:24:42 UTC
Thank you for your feedback, so I put it as a dup.

*** This bug has been marked as a duplicate of bug 47368 ***
Comment 6 Roman Eisele 2012-09-12 14:58:14 UTC
Mac Accessibility Related Bugs Survey Results
---------------------------------------------

All tests done on Mac OS X 10.6.8 (Intel).

Using the steps given in comment #0, the crash is REPRODUCIBLE with
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: cfbfa26,
  Pull time: 2012-09-07 10:35:10, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 5ca197c,
  Pull time: 2012-09-06 07:07:33, US English langpack installed

But the crash is NO longer reproducible with
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: c303961,
  Pull time: 2012-09-11 08:49:57, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 2df0884,
  Pull time: 2012-09-11 01:28:39, US English langpack installed

This indicates that this bug was fixed by Michael Meek’s patch for bug 47368:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=3234b715b5a6d13ee673b41066eb565706be5ec9

Additionaly, this is also indicated by the stack trace attached to the present bug: it shows much (endless?) recursion of hitTestRunner(); Michael’s patch is exactly a fix for this endless hitTestRunner() recursion.

This means in turn that this bug is correctly marked as a duplicate of bug
47368, which was fixed by the commit cited above.

This fix will appear in LibreOffice 3.6.2 and 3.7.0.
Comment 7 Roman Eisele 2012-09-13 11:33:04 UTC
To make it easier to reproduce/test this issue for everybody else, let me add some missing details:


(In reply to comment #0)
> Steps to reproduce:
> 1. Start LibreOffice Writer (tested on MacOS 10.6.8)
> 2. In the default "blank" document, show the panel that lists all the styles

  -> This is the “Styles and Formatting” panel, available via “Format > Styles and Formatting”.

> 3. Double click on a style that has children (with one gray arrow)

  -> To show the “gray arrow”, and to reproduce this bug, you need first to select the mode “Hierarchical” from the popup menu at the bottom of the “Styles and formatting” panel.


(In reply to comment #6)
> All tests done on Mac OS X 10.6.8 (Intel).

  -> I forgot to mention that I can only reproduce this (and similar) bugs with some window management utility running which provokes the accessibility-related crashes, in my case: RightZoom.
Comment 8 Julien Nabet 2012-09-13 11:43:46 UTC
Since Roman still reproduces the problem, I reopen this bugtracker.
Moreover, I had put it as a dup of 47368 and as Rainer said, a bug can't be a dup of a task ; my fault then.

Roman: get ready to test when 3.6.2 will be released ;-) (perhaps fixes of these last days about accessibility may help)
Comment 9 Roman Eisele 2012-09-13 13:15:59 UTC
(In reply to comment #8)
> Since Roman still reproduces the problem, I reopen this bugtracker.

No, sorry: as said above, I can only reproduce it until
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: cfbfa26,
  Pull time: 2012-09-07 10:35:10, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 5ca197c,
  Pull time: 2012-09-06 07:07:33, US English langpack installed

But I can *********** NOT **************reproduce it anymore with
* LibreOffice 3.6 daily (3.6.2.0+), Build ID: c303961,
  Pull time: 2012-09-11 08:49:57, German langpack installed
* LOdev 3.7.0.0.alpha0+, Build ID: 2df0884,
  Pull time: 2012-09-11 01:28:39, US English langpack installed

So this crash IS fixed, and therefore the report can stay closed.

> Moreover, I had put it as a dup of 47368 and as Rainer said, a bug can't be a
> dup of a task ; my fault then.

Yes, but bug 47368 is only a task bug since a few days, and I am going to REMOVE the "[Task]" from that bug again and creating a new Task bug for all remaining Accessibility issues. IMHO bug 47368 should be handled as a normal bug for exactly two accessibility issues: the issues (I) and (II), listed somewhere in the mid of that lengthy report, and now both fixed because of the two patches by Tor and Michael. Therefore, this bug, like any other fixed by these two patches, should stay a duplicate of bug 47368 ...

Sorry, you could not know that, but I can just not do everything at the same time: test 30 bugs, each with 4 or more different LibreOffice builds, AND create new taks bugs, and explain that all ...

> Roman: get ready to test when 3.6.2 will be released ;-)

I have already spent 3 days full of testing of ALL bugs about accessibility, and I am still not through with all of them. Once I have tested them all, I will create the mentioned new Task bug for all remaining bugs.

Thank you, and sorry: I am mid in my big survey of Mac accessibility related bugs, and therefore we have an inconsistent state of affairs until I’m finished.

*** This bug has been marked as a duplicate of bug 47368 ***