Bug 53328 - CRASH when FILEOPEN particular .txt in particular way
Summary: CRASH when FILEOPEN particular .txt in particular way
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-08-10 09:05 UTC by Rainer Bielefeld Retired
Modified: 2012-08-16 04:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (40.49 KB, application/x-7z-compressed)
2012-08-10 09:05 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-10 09:05:50 UTC
Created attachment 65374 [details]
Test Kit

Steps how to reproduce with Server Installation of  "LibreOffice 3.6.0.4  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit) and attached test kit:

0. Download / unzip test kit.
1. Launch LibO
2. From LibO Start Center: menu 'File -> Open - doc.ods' <open>
   Spreadsheet will be opened
3. menu 'File -> Open - WebHmiCrossRef.txt' <open>
   CRASH

The crash is not reproducible for any FILEOPEN, only from "doc.ods" and several other spreadsheets.

"WebHmiCrossRef.txt" is a text document generated by a PLC programming environment, I never had problems with these documents.

CRASH also happens with parallel installation of Master "LOdev  3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 3ea6b1c]" (tinderbox:Win-x86@6, pull time 2012-08-09 00:01:28). Here I have to preselect filetype "Text .txt / .csv, without that selection LibO will open the document as .csv (on my PD), what might be a separate bug.

No CRASH with 3.5.6.1, so Regression.
Comment 1 Not Assigned 2012-08-10 22:19:21 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d8cd0abb8e4b1b891e982d10f57de108aaca1ea

fdo#53328: sw: ascii import: fix crash:
Comment 2 Michael Stahl (CIB) 2012-08-10 22:27:37 UTC
have fixed the crash in the Writer ASCII import filter.

but that was only introduced last week and is not in the 3.6 version.

cannot get 3.6 to crash with this text document.
Comment 3 Rainer Bielefeld Retired 2012-08-11 14:14:31 UTC
@Michael:
Thank you for the very quick fix. It seems that the problem has various appearances under different (unknown) circumstances. I also saw the the crash with other .txt documents, but that combination in test kit was the only one 100% reproducible for me.

With  parallel installation of Master "LOdev  3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7d8cd0a]" (tinderbox: 2008R2@20, pull time 2012-08-10 23:27:17) the crash is no longer reproducible for me, but I think I should try an additional build.
Comment 4 Rainer Bielefeld Retired 2012-08-11 14:46:24 UTC
Also now works fine with Server Installation of  "LibreOffice 3.6.1.0+  English UI/ German Locale [Build-ID:  b0aac2a] on German WIN7 Home Premium (64bit)  {tinderbox: Win-x86@9, pull time 2012-08-11 00:16:39}

So I recommend a backport to 3.6.1 and to close this bug, because at least 1 important root of the problem is fixed. I will continue to observe this and submit a new Bug if I observe similar problems with latest builds.

I modified Status and Assignee doe to facts,

@Michael: I hope you agree.
Comment 5 Michael Stahl (CIB) 2012-08-13 10:02:37 UTC
according to the description this is a Calc bug anyway, so the only
reason why i fixed that Writer master-only regression is that
i can't read bug descriptions :)

still can't reproduce the reported Calc crash in 3.6.0.4 though
Comment 6 Rainer Bielefeld Retired 2012-08-13 11:16:57 UTC
I wonder what I thought when I wrote comment 4, WFM with 3.6.1.0+ says that 
a) no backport required is required, because there is no problem
b) the reason for WFM with 3.6.1.0+ can not be Michaels fix, because the fix is 
   not in that version
c) and so the WFM with 3.6.1.0+ only was "lucky chance.

Also works fine with Server Installation of  "LibreOffice 3.6.1.0+  English UI/ German Locale [Build-ID:  cd656ac] on German WIN7 Home Premium (64bit)  {tinderbox: Win-x86@9, pull time 2012-08-12 21:30:17}

and - tadaa: also no longer reproducible with 3.6.0.4

So I believe we can make this one WFM and enjoy Michaels fix for an unknown, completely different problem :-)
Comment 7 Eike Rathke 2012-08-13 11:36:49 UTC
Was the crash with fixed width fields enabled in the import dialog? If so, this would be a duplicate of bug 53012 fixed in master and for 3.6.1
Comment 8 Rainer Bielefeld Retired 2012-08-13 15:19:50 UTC
@Eike:
No, we are talking about opening a WRITER.txt document
Comment 9 Michael Stahl (CIB) 2012-08-13 15:24:45 UTC
Rainer, it seems to me Eike is talking about the crash you reported in
Description, which is clearly using the Calc .txt import (that's why
it only crashed for you after loading a spreadsheet document:
by default .txt files are opened by Writer, except if you're using
Calc to open the file).
Comment 10 Rainer Bielefeld Retired 2012-08-13 16:06:39 UTC
@Michael, Ike:
I never talked about a "Open .csv" problem; may be my report is mistakable. The Crash happened when I opened "WebHmiCrossRef.txt" via the Writer open (if necessary to force LibO to open in Writer: "Encoded") Text dialog.

I only did the fileopen from "doc.ods" because from there the crash was 100% reproducible for me for a while (I also saw the crash opening from Writer documents, others not tested), but the Crash happened in the Writer fileopen process.
Comment 11 Rainer Bielefeld Retired 2012-08-13 16:09:51 UTC
I agree, Spreadsheet component is worrying, I used it because for a while it looked that the problem might be related to "Open from Spreadsheet file dialog". But that's not the case, before the problem vanished I also saw some crashes opening "WebHmiCrossRef.txt" documents (these documents always are created with this name) from Writer dialog.
Comment 12 Rainer Bielefeld Retired 2012-08-16 04:46:37 UTC
New similar problem: "Bug 53569 - FILEOPEN particular text document with wrong name extension causes CRASH"