Download it now!
Bug 53341 - Broken DEB packages
Summary: Broken DEB packages
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, skillScript, topicCleanup
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-08-10 12:20 UTC by Thorsten Glaser
Modified: 2015-12-16 00:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thorsten Glaser 2012-08-10 12:20:00 UTC
Several package relationship fields in the DEB packages provided look like this:

Provides: libobasis36-en_GB

Spot the two(!) errors with that.

.

.

.

Neither uppercase letters nor underscores are allowed.

Fix:

Provides: libobasis36-en-gb

$(tr A-Z_ a-z-)

And that with all such fields (Package, Depends, Provides, etc).

Debian Policy §5.6.1 (4)
Comment 1 Thorsten Glaser 2012-08-30 14:45:27 UTC
Add to blocking list for 3.6 because installing the currently-shipped broken packages makes other Debian software complain about the invalid state of the package database.

The bug is RECONFIRMED for libreoffice3.6-en-gb=3.6.1.2-2 (for example).
Comment 2 Michael Meeks 2012-10-08 18:22:50 UTC
Currently we use 'epm' to package the packages; it'd be great to have a patch to EPM to correct that, or better still to correct the name of the package in the heavy-lifting that produces that. I believe that is located in:

http://cgit.freedesktop.org/libreoffice/core/tree/solenv/bin/modules/installer/epmfile.pm

patches much appreciated.
Comment 3 Michael Meeks 2012-10-09 08:51:12 UTC
Rene, I wonder if this causes grief for you from time to time :-) it's a 3.6 MAB apparently.
Comment 4 Rene Engelhard 2012-10-09 09:08:47 UTC
as we don't use the broken .debs coming out of the build systen - no :)

(and I have http://anonscm.debian.org/gitweb/?p=pkg-openoffice/libreoffice.git;a=blob;f=rules;h=4f9d98804beddb2ae5e79fe07dcd1d02d88191e6;hb=HEAD#l1702)
Comment 5 Michael Meeks 2012-10-09 09:31:58 UTC
The link suggests:

1702         # fixup case (-l10n-pt-BR -> l10n-pt-br etc.)
1703         for iso in $(ISOS); do \
1704                 pkgiso=`echo $$iso | tr A-Z a-z`; \
1705                 if [ "$$iso" != "$$pkgiso" ]; then \
1706                         if [ "$$iso" != "en-US" -a \

Bjoern - random packaging bug hurting Ubuntu / Debian package users. Any chance you could take a look ? [ it's a MAB seemingly ].
Comment 6 Michael Meeks 2012-11-14 09:15:05 UTC
This should be fixed on master - but it can't be back-ported to 3.6.

Testing of a recent build there is much appreciated - I don't have apt installed on my system.

Thanks !
Comment 7 Thorsten Glaser 2012-11-14 17:01:02 UTC
Sure, if you point out the build, I can’t seem to find nightly builds of i386 debs other than old ones for 3.5 and 3.6…
Comment 8 Robinson Tryon (qubit) 2015-12-16 00:19:47 UTC
Migrating Whiteboard tags to Keywords: (EasyHack,DifficultyBeginner,SkillScript,TopicCleanup)
[NinjaEdit]