Bug 53351 - UI: Scroll bars do not always work on Mac OS X
Summary: UI: Scroll bars do not always work on Mac OS X
Status: RESOLVED DUPLICATE of bug 46271
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) macOS (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-10 19:29 UTC by Ralph Martin
Modified: 2013-06-10 15:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Attempt of sample file: 4000-lines ODS file, very simple (16.58 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-09 06:24 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Martin 2012-08-10 19:29:49 UTC
On MacOS X (10.7 or 10.8), open a long spreadsheet, with say 3000 rows.

The vertical scrollbar shows a handle to drag, to scroll the document up and down.
When at or near the top of the document, attempts to drag the handle fail.
When near the bottom of the document, dragging the handle works as expected.
Further experiments show that the problem seems to be a miscalculation of the position of the click on the scroller, relative to the position of the handle: clicking above or below the handle can cause incorrect direction of movement of the document up or down too.

This problem has existed for the last few versions of LibreOffice.
Comment 1 Roman Eisele 2012-08-18 11:08:33 UTC
For now, just a hint: related to bug 44974?
Comment 2 Roman Eisele 2012-10-05 08:28:20 UTC
Thank you very much for your bug report!

I can not confirm it -- I am using Mac OS X 10.6.8, and there the vertical scrollbr works well under most circumstances, so this problem seems to be related to the Mac OS X version.

Can you please check yourself if this is the same issue (I can not tell for sure) as bug 46271 - “UI: Vertical scroll bar cannot be properly dragged under Mac OS X Lion 10.7.3”? This would be very helpful!

Thank you in advance!
Comment 3 Ralph Martin 2012-10-05 08:33:47 UTC
It may be a related bug, but it is different incorrect behaviour.

The scrollbar appears as a white area with a short grey handle to move the contents.

When the handle is near the top, grabbing the handle and trying to pull it down to scroll through the document simply does not work.
Comment 4 Roman Eisele 2012-10-09 06:17:17 UTC
@ Ralph Martin:
Thank you for clarification!

Confining to Calc (“Spreadsheet”) for now.
Trying to reproduce ...
Comment 5 Roman Eisele 2012-10-09 06:24:42 UTC
Created attachment 68315 [details]
Attempt of sample file: 4000-lines ODS file, very simple


I have created a very simple sample file (4000 rows, but little text per rows, to make sure that only the column count is important), but when playing around with it in LibreOffice 3.6.2.2 on Mac OS X 10.6.8 (Intel) I can not reproduce the wrong behaviour (the scrollbar always works fine). So this problem seems to be limited to Mac OS X >= 10.7.
Comment 6 Roman Eisele 2012-10-09 06:25:57 UTC
@ Alex Thurgood:

This little UI bug seems to be limited/related to Mac OS X >= 10.7; can you please try to reproduce/confirm it?

Thank you very much!
Comment 7 Alex Thurgood 2012-10-10 09:18:14 UTC
Confirming on my master build 3.7.0 from 07/10/2012.

There appears to be a coordinate recognition problem. The problem occurs for me both at the top and bottom of the test document Roman provided. Very annoying behaviour indeed !

OSX 10.8.2

Alex
Comment 8 Roman Eisele 2012-10-10 13:31:20 UTC
@ Alex:

Thank you very much for testing and confirming!
Can you also reproduce this with 3.6.x?
Comment 9 Alex Thurgood 2013-06-10 15:00:45 UTC
For me, this is a DUP of 46271, setting as such.

*** This bug has been marked as a duplicate of bug 46271 ***