Bug Hunting Session
Bug 53410 - UI: Installation directory path and disk space button are disabled if excluded components are selected
Summary: UI: Installation directory path and disk space button are disabled if exclude...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All Windows (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-08-12 14:52 UTC by Réka Szabó
Modified: 2014-02-15 16:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
On the left an included component is selected and the expected behavior can be seen, on the right an excluded component is selected and the problem can be seen (61.59 KB, image/png)
2012-08-12 14:52 UTC, Réka Szabó
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Réka Szabó 2012-08-12 14:52:25 UTC
Created attachment 65468 [details]
On the left an included component is selected and the expected behavior can be seen, on the right an excluded component is selected and the problem can be seen

Problem description: 
Directory of the installation disappears and cannot be modified if a component is selected which is excluded from the install. Same behavior appears with the disk space button.

Steps to reproduce:
1. Double-click on the installer
2. Choose custom installation
3. Choose a component which is not intended to be installed (the ones with the X marks) or make a component not to install.

Current behavior:
- Path of the "Install to" directory disappears
- Space button disappears

Expected behavior:
Regardless of the selected components, both the installation directory path and the query of disk space should be always available.

Platform: 
Windows 7 64-bit
Comment 1 Joel Madero 2013-11-23 03:01:39 UTC
Let me start by apologizing that it took this long to address this. That being said, I can confirm this. 

Windows 8
LibreOffice 3.5.7 (our version field is oldest version that we can confirm the problem)


Setting to:
New

Critical - inability to install essentially - a lot of people want to install to a separate drive and this only allows it if you install the entire suite. This being said, unlike Microsoft Office or other suites, each component is part of a larger individual product so not installing one thing is not saving you much at all in terms of space. None the less I think critical is appropriate.

Highest

Most Annoying Bug

Additional info that makes it even worse:
If you select your separate drive prior to deselecting a component, it actually installs to the appropriate drive but then it's a corrupt install and you can't run it.

Thanks for reporting!
Comment 2 Tor Lillqvist 2013-11-23 07:31:23 UTC
Well, in 4.2 there will be no possibility to (misguidedly) pick and choose among "components" (meaning Writer, Calc, Draw etc) any more. Which is good. Despite the marketing, LibreOffice is not a "suite" of separate programs. It has never worked properly anyway to pick and choose among these "components"; leaving out some "component" has made some use cases of other "components" fail, etc.

But as such, this bug is still present, if one de-selects on of the (truly) optional components, the possibility to change installation location disappears.
Comment 3 stragu 2014-02-12 08:21:06 UTC
Could someone test if this is still an issue in 4.1?
Comment 4 tommy27 2014-02-15 16:59:47 UTC
Tor Lillquist is right.

see: https://wiki.documentfoundation.org/ReleaseNotes/4.2#Installer_.28win_only.29

basically this means that this issue will not be present anymore in future LibO releases.

I change status to RESOLVED WONTFIX