Download it now!
Bug 53429 - : Problem with loading (auto-detected) Java on startup
Summary: : Problem with loading (auto-detected) Java on startup
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-13 04:20 UTC by Dr. Mark Marzinzik
Modified: 2013-06-26 08:02 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Mark Marzinzik 2012-08-13 04:20:57 UTC
Problem description: 

Steps to reproduce:
1. Select the *one* auto-detected installed Java runtime in preferences.
2. Edit a document on a page greater than 1.
3. Save document.
4. Quit LibreOffice Writer.
5. Open Writer and document again by double-clicking the document in Windows explorer.

Current behavior:

The cursor does not get positioned at the last edited place.
Further observation: When going in Java preferences of LibreOffice, there is a time delay until the (auto-detected) JRE is shown.
Probably, the JRE is not started fast enough at start of LibreOffice to produce expected behavior (see below). 

Expected behavior:

With LibreOffice Writer 3.5 the cursor got positioned at last edited place *if* a Java JRE is used. This is not working anymore with 3.6.0.4.

Platform (if different from the browser):

Windows 7 Home Premium x64 with Oracle Java 1.7 Uodate 5. 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Thomas Hackert 2013-06-25 16:07:04 UTC
Hello Dr. Marzinzik, *,
I cannot reproduce your bug with LO Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 under Debian Testing (as well as the stable Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2) ) ... :( Would you be so kind to test it again with a newer version than LO 3.6.0.4, please? Is this bug fixed there? If not, it would be nice, if you could do it ... ;) And can you attach a document to this bug, if it is not fixed, so we are able to reproduce it. But then we need further information as well:
1. Which OS/architecture are you using?
2. Which Java version do you use?
3. Have you installed only one version of it?
4. What exactly do you mean with point 1? Wasn't it selected before?

Sorry for the inconvenience
Thomas.
Comment 2 Dr. Mark Marzinzik 2013-06-26 03:38:41 UTC
Problem is already solved.

Regards,
Mark


2013/6/25 <bugzilla-daemon@freedesktop.org>

> thackert@nexgo.de changed bug 53429<https://bugs.freedesktop.org/show_bug.cgi?id=53429>
>  What Removed Added  Status UNCONFIRMED NEEDINFO  Ever confirmed   1
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=53429#c1> on bug
> 53429 <https://bugs.freedesktop.org/show_bug.cgi?id=53429> from
> thackert@nexgo.de *
>
> Hello Dr. Marzinzik, *,
> I cannot reproduce your bug with LO Version: 4.1.0.1 Build ID:
> 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 under Debian Testing (as well as the
> stable Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2) )
> ... :( Would you be so kind to test it again with a newer version than LO
> 3.6.0.4, please? Is this bug fixed there? If not, it would be nice, if you
> could do it ... ;) And can you attach a document to this bug, if it is not
> fixed, so we are able to reproduce it. But then we need further information as
> well:
> 1. Which OS/architecture are you using?
> 2. Which Java version do you use?
> 3. Have you installed only one version of it?
> 4. What exactly do you mean with point 1? Wasn't it selected before?
>
> Sorry for the inconvenience
> Thomas.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Thomas Hackert 2013-06-26 08:02:13 UTC
Hello Dr. Marzinzik, *,
thank you for your comment 2 :) Because of it I close this bug as resolved worksforme, as it is not clear, what leads to the fix ... :(
Sorry for the inconvenience
Thomas.