Bug 53452 - docx import mangles tables
Summary: docx import mangles tables
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-13 18:23 UTC by dru_ed
Modified: 2015-04-10 08:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example document exhibiting behavior (386.27 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-08-13 18:31 UTC, dru_ed
Details
PDF printed from Mac Word 2011 (603.40 KB, application/pdf)
2015-04-10 08:23 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dru_ed 2012-08-13 18:23:11 UTC
Data ends up outside tables, pagination effected. Document saved from Word 2010.
Comment 1 dru_ed 2012-08-13 18:31:24 UTC
Created attachment 65509 [details]
example document exhibiting behavior

Document saved from Word:mac 2008. Displays correctly in Word 2010, Windows.
Comment 2 s-joyemusequna 2012-08-14 14:51:18 UTC
Confirmed with LibO 3.3.4, 3.4.5, 3.5.5, 3.6.0, and 3.7 dev under Windows XP and Vista 64.
Comment 3 Jorendc 2013-12-28 23:07:03 UTC
Still reproducible using Windows 8.1 with LibreOffice Version: 4.3.0.0.alpha0+
Build ID: 5be7ec4193b892e5643ff5f3f2e6755319569190
TinderBox: Win-x86@39, Branch:master, Time: 2013-12-27_23:55:02

PS: bug version is 3.3.4, because that's the oldest reproducible version of LibreOffice the bug is reproduced. (see comment 2)

Thanks
Joren
Comment 4 Matthew Francis 2015-04-10 08:23:37 UTC
Created attachment 114713 [details]
PDF printed from Mac Word 2011
Comment 5 Matthew Francis 2015-04-10 08:35:33 UTC
Around 4.2 the rendering for this file was quite decent, so the original issue circa 3.3 was resolved.

There are however more recent regressions with the file, which I will find or open new bugs for, then link here.

-> Status: RESOLVED WORKSFORME