Bug 53491 - FILEOPEN: "Detect special numbers" option during text import seems to be backwards?
Summary: FILEOPEN: "Detect special numbers" option during text import seems to be back...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Format-Filters Help-Changes-Features
  Show dependency treegraph
 
Reported: 2012-08-14 12:50 UTC by skoehler
Modified: 2018-09-30 19:29 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
An example TSV file showing the issue with exponential-formatted numbers. (10 bytes, text/tab-separated-values)
2012-08-14 12:50 UTC, skoehler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description skoehler 2012-08-14 12:50:54 UTC
Created attachment 65544 [details]
An example TSV file showing the issue with exponential-formatted numbers.

Problem description: 
Selection of the detect special numbers seems to work backwards from documentation (http://help.libreoffice.org/Common/Text_Import#Detect_special_numbers) and (at least my) expectations.

Steps to reproduce:
1. Open temp.tsv (attached) using scalc
2. Select (or don't select) "Detect special numbers" on import.

Current behavior:
"Detect special numbers" selected -> 3E is left as text
"Detect special numbers" unselected -> 3E is converted to 3

Expected behavior:
The exact opposite behavior (but with the option still left unselected by default...I believe this matches Excel's behavior, not that Excel is the touchstone to meet :) ).

Platform (if different from the browser): CentOS 5.6, x86_64
              
Other notes: Interestingly, the documentation seems to be incorrect either way about not interpreting any exponential number...you'll notice that the 2nd item in temp.tsv (3E2) is interpreted as a number regardless of this option's value.  However, Excel does the same thing, so I actually prefer it that way for interoperability purposes.  In any event, this software is truly great, thanks!  And, as always, I apologize in advance if this is something braindead that I'm not understanding properly.

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Juan Canham 2012-12-23 20:34:28 UTC
Confirmed on Version 3.6.2.2 (Build ID: 360m1(Build:2)) on Kubuntu 12.10
Comment 2 QA Administrators 2015-01-05 17:51:17 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2016-11-08 10:38:50 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2018-09-30 19:29:57 UTC
I can't confirm that with 

Version: 6.2.0.0.alpha0+
Build-ID: 62cd86977ca41677c56fb2d1f97bb1c5cbdbd416
CPU-Threads: 4; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: threaded

With special numbers activated Calc imports:
3E
3,00E+02
4F

Without special numbers activated Calc imports:
3E
300
4F

This matches what the help says:
'When this option is enabled, Calc will automatically detect all number formats, including special number formats such as dates, time, and scientific notation.'
https://help.libreoffice.org/6.1/en-US/text/shared/00/00000208.html?&DbPAR=CALC&System=UNIX

I close this bug as RESOLVED WORKSFORME.

Please reopen as NEW if the problem still occurs in your installation. Please test with the newest possible LibreOffice version for your OS.