Download it now!
Bug 53510 - Restore/Don't Restore Windows OSX Bug
Summary: Restore/Don't Restore Windows OSX Bug
Status: RESOLVED DUPLICATE of bug 39007
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 RC1
Hardware: Other Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-14 21:51 UTC by Mike Anton
Modified: 2012-08-24 17:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Grab of the OSX "Restore/Don't Restore Windows" prompt over a locked-out LibreOffice (230.02 KB, image/tiff)
2012-08-14 21:51 UTC, Mike Anton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Anton 2012-08-14 21:51:50 UTC
Created attachment 65570 [details]
Grab of the OSX "Restore/Don't Restore Windows" prompt over a locked-out LibreOffice

Problem description: 

Inability to disable the "Restore Windows" OSX prompt.

Steps to reproduce:
1. LibreOffice wouldn't close while I was logging out/shutting down my MacBook (OSX 10.7.4) so I force quit.
2. Restarted my computer, opened LibreOffice, OSX-based prompt came up, would not respond to clicks on either "Restore Windows" or "Don't Restore Windows."
3. LibreOffice's internal restore windows prompt came up. Have both restored and not restored windows. Either way, OSX prompt refuses to leave, which renders program useless.
4. This error occurs in OpenOffice as well, as I downloaded that as alternative and received the same OSX-based error.

Current behavior:

Locked up based off of Restore/Don't Restore Windows prompt

Expected behavior:

Fully functioning -- and wonderful -- LibreOffice

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Roman Eisele 2012-08-24 17:56:35 UTC
Hello Mike Anton,

thank you very much for your bug report! I agree with you that this is a
critical issue. It is already known, therefore I mark this report as a
duplicate of the main bug report for this issue -- bug 39007.

In the report for bug 39007 you will find some suggestions how to solve the
problem, at least for some time (see comments no. 2, 6, and 20 there).
Basically, you need to delete the file
    "org.libreoffice.script.savedState"
from the folder
    "~/Library/Saved Application State/"
(~ is your user/home folder) and to reboot your Mac.

I hope that our developers will fix this issue soon and for good, but it seems
it is not easy to fix, it is some kind of terrible "misunderstanding" between
LibreOffice and MacOS X >= 10.7 (AFAIK >= 10.7 only).

*** This bug has been marked as a duplicate of bug 39007 ***