Download it now!
Bug 53527 - EDITING ReportBuilder Field names not shown
Summary: EDITING ReportBuilder Field names not shown
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.1.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.6.2.1
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-08-15 06:27 UTC by Robert Großkopf
Modified: 2012-09-14 15:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Report with some textfields - content shown in LO 3.3.4, not shown in 3.6.1+ (24.00 KB, application/vnd.sun.xml.base)
2012-08-15 06:27 UTC, Robert Großkopf
Details
Description about this bug and another bug (user defined function) (37.33 KB, application/vnd.oasis.opendocument.text)
2012-08-15 06:28 UTC, Robert Großkopf
Details
ReportBuilder_Textfields_without_Contentmarker (6.85 KB, image/png)
2012-08-18 13:23 UTC, Jochen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2012-08-15 06:27:17 UTC
Created attachment 65585 [details]
Report with some textfields - content shown in LO 3.3.4, not shown in 3.6.1+

The following bug appears in Version 3.6.1.0+ (Build ID: cd656ac) (could not choose this for the bug-report).
Open the attached database.
Open the report for editing the report.
In LO 3.3.4 appear labelfields and textfields. The textfields show the content of the database, written in a light grey characters.
In LO 3.6.1.0+ the information about the content of the database has gone.
Comment 1 Robert Großkopf 2012-08-15 06:28:23 UTC
Created attachment 65586 [details]
Description about this bug and another bug (user defined function)
Comment 2 Robert Großkopf 2012-08-16 15:26:49 UTC
I can confirm this behaviour with 3.6.1.1 rc. Have corrected the version and set the platform to my platform. Also the status to new.
Comment 3 Jochen 2012-08-18 13:23:22 UTC
Created attachment 65737 [details]
ReportBuilder_Textfields_without_Contentmarker
Comment 4 Jochen 2012-08-18 13:23:47 UTC
Hi Robert,

file in attach 1 can´t be used -> connection to datasource "ReportBuilder_Textfields_without_Contentmarker" can´t be ... (s. attach 3)
Comment 5 Jochen 2012-08-18 13:56:02 UTC
Hi Robert,

I have tested a Base-document of my own. Here are the results:

Problem 1 "name of the fields in the textfields":
Using MS Windows XP I see the name of the fields in the textfields.
May be a Linux-problem?!

Problem 2 "User defined Function":
Using MS Windows XP I also don´t see the "User defined Function" "[Priceadd]". May be a correct behavior? I don´t know what "[Priceadd]" means/does.
Comment 6 Jochen 2012-08-18 13:57:10 UTC
Sorry: I have tested with LO 3.6.0
Comment 7 Robert Großkopf 2012-08-19 14:22:44 UTC
(In reply to comment #4)
> file in attach 1 can´t be used -> connection to datasource
> "ReportBuilder_Textfields_without_Contentmarker" can´t be ... (s. attach 3)

Hi Jochen,

I have just downloaded attachment 1. Can be opened and editited with LO 3.3.4 and LO 3.6.1 RC1. No Problem with that file.

The Function [priceadd] is a user-defined-function in the report of attachment 1. You can't see it in another report.
Comment 8 Jochen 2012-08-19 14:48:36 UTC
Hi Robert,

I can´t open file in attach 1 by using LibreOffice 3.5.5.3 Build-ID: 7122e39-92ed229-498d286-15e43b4-d70da21 (OS Windows 7 Prof 64 Bit) and by using LO 3.6.0 (OS Windows XP 32 Bit).
Following two error-messages occur:
Error 1:
Die Verbindung zur Datenquelle "ReportBuilder_Textfields_without_Contentmarker" konnte nicht hergestellt werden.
(The connection to datasource "ReportBuilder_Textfields_without_Contentmarker" could not be made).
Error 2:
SQL-Status: S1000
Fehler-Code: -40
General error: org.hsqldb.lib.FileSystemRuntimeException: java.io.IOException: c:/onegit/package/source/xstor/xstorage.cxx:3180:

Comment1:
1) You are using Linux. I´m using Windows.
2) This problem is not the problem you have reported, but also interestingly. Further discussion on de-discuss-ML?


Back to your bug-report/request:
I have tested a Base-document of my own. Here are the results for LO 3.6.0:

Problem 1 "name of the fields in the textfields":
Using MS Windows XP I see the name of the fields in the textfields.

Problem 2 "User defined Function":
Using MS Windows XP I also don´t see the "User defined Function" "[Priceadd]".

IMHO we need another tester using Linux (and/or Windows).
Comment 9 Alex Thurgood 2012-08-19 18:01:18 UTC
Hi all,

Opened the file attached to issue on Linux Mint 12 64bit.

With LO 3.4.4 (Mint provided)

I can see the description of the text fields in the report when in Edit mode.

However, I can't see any of the functions that Robert mentions in his bug report. None of the fields I have looked at Group, Article or Price, have any associated function defined in the Data tab, or anywhere else that I can see, for that matter.

Will test next on 3.5.5.2, then 3.6.0.4


Alex
Comment 10 Alex Thurgood 2012-08-19 18:11:10 UTC
LO 3.5.5.2 : same as for 3.4.4, no user defined functions are visible
LO 3.6.0.4 : same as for 3.4.4, no user defined functions are visible


Not sure whether that helps very much.

Robert, are you sure you  uploaded the right file ?


Alex
Comment 11 Alex Thurgood 2012-08-19 18:20:31 UTC
OK, I have now managed to add the user defined function Priceadd that Robert was talking about to the group footer in 3.4.4 to my version of the file that I downloaded from the attachment on this issue.


Now to play with it in 3.5 and 3.6
Comment 12 Alex Thurgood 2012-08-19 20:29:57 UTC
I can see PriceAdd in 3.5.5.2 and 3.6.0.4 on Linux Mint 12, 64bit.

So, unfortunately, I can not reproduce the problem that Robert mentions.



Alex
Comment 13 Alex Thurgood 2012-08-19 20:31:19 UTC
Maybe this is a Linux 32bit only problem ?


Alex
Comment 14 Jochen 2012-08-19 20:42:07 UTC
I could now open the file.

Results:
In Windows 7 and LO 3.5.5 no problems, i.e. problems ("name of the fields in the textfields" and "User defined Function") are not reproducible using Windows.

@Robert:
May be a special Linux-problem (again).
Comment 15 Robert Großkopf 2012-08-21 07:07:15 UTC
I have now tested it on another OpenSuSE 11.4-32-bit-system.
I could open the database from attachment 1 without problems. And I do not see any hint to the content, when I open the report for editing.

In LO 3.3.4 on the same machine is shown "=Group" in italic - light grey in the field for the group - in LO 3.6.1 RC 1 it didn't appear.

Again a Linux-rpm-problem??
Comment 16 Robert Großkopf 2012-08-21 07:13:35 UTC
Now, when I have had a look to all comments, I see one more problem: The Bug only appears with LO 3.6.1.1 rc. I have not tested it with 3.6.0, because, all databases with Linux-rpm were destroyed when opening them with LO 3.6.0.

This is a bug of 3.6.1.1 rc, not a bug of 3.5.x - there it works all right.

Could you please test it with this version again?
Comment 17 Rainer Bielefeld Retired 2012-08-21 07:45:56 UTC
[Reproducible] with "LibreOffice 3.6.1.1  German UI/Locale [Build-ID:  4db6344] on German WIN7 Home Premium (64bit), grey "= Field Name" contents is not shown. But relation seems to be intact, correct field names shown in properties area.

Worked fine with 3.6.0.4, so rather new problem, Regression!

Still [Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   - WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 6900781]" (tinderbox: 2008R2@20, pull time 2012-08-14 09:27:23)

@All:
If you do tests with databases and especially reports using server installations, please always terminate all other LibO versions. Running different Versions in parallel causes strange effects like "no connection" or similar.

@Lionel:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 18 Rainer Bielefeld Retired 2012-08-21 07:46:59 UTC
Comment on attachment 65737 [details]
ReportBuilder_Textfields_without_Contentmarker

Has nothing to do with reported problem
Comment 19 Rainer Bielefeld Retired 2012-08-21 07:52:15 UTC
Already [Reproducible] with Server Installation of  "LibreOffice 3.6.1.0+  English UI/ German Locale [Build-ID:  cd656ac] on German WIN7 Home Premium (64bit)  {tinderbox: Win-x86@9, pull time 2012-08-12 21:30:17}
Comment 20 Alex Thurgood 2012-08-21 09:05:10 UTC
(In reply to comment #17)

> @All:
> If you do tests with databases and especially reports using server
> installations, please always terminate all other LibO versions. Running
> different Versions in parallel causes strange effects like "no connection" or
> similar.
> 

Hi Rainer, on Linux, we don't generally have server installations in default distribution settings, however, if one installs the "docvert" utility by mistake or as a result of a package dependency without the user knowing about it, then the default LibreOffice installation does get started as server process, listening for connections to be initiated...some users might not realise that this is going on. I didn't, until I looked at my running soffice processes the other day on my Linux box.


Alex
Comment 21 Alex Thurgood 2012-08-21 09:35:40 UTC
Confirming on Mac OSX 10.8 with 
Version 3.7.0.0.alpha0+ (Build ID: 9e04ae0)


The bound fields are no longer visible in the sections of the report being designed.

I tried to add the PriceAdd function in the group footer, but this is no longer displayed in the dropdown list which is empty.

Changing platforms to ALL/ALL

Alex
Comment 22 Alex Thurgood 2012-08-21 09:38:38 UTC
Definitely a regression over 3.5, and all other previous release versions from my testing.
Comment 23 Jochen 2012-08-21 20:51:23 UTC
I can now confirm the two problems ("name of the fields in the textfields" and "User defined Function [Priceadd]") for LO 3.6.1.1 using Windows XP.
Conclusion:
1) It is a regression.
2) Concerning platforms Windows ans Linux
Comment 24 Alex Thurgood 2012-08-22 06:22:37 UTC
Added link to 52399, perhaps related ?

Alex
Comment 25 Thomas Hackert 2012-09-02 11:04:31 UTC
Hello Robert, *,
sorry for the delay, but too much to do the last week ... :(

I can confirm both bugs with LO Version 3.6.1.2 (Build ID: e29a214) and Germanophone langpack under Debian Testing AMD64 ... :(
HTH
Thomas.
Comment 26 Lionel Elie Mamane 2012-09-14 15:47:27 UTC
Can reproduce on 3.6.1.1 (Build ID: 4db6344) official .deb x86-64 binaries.

Cannot reproduce in my 3.6 dev tree.

Cannot reproduce in 3.6.2.1 official .deb x86-64 binaries.

Assuming fixed somehow in 3.6.2.1, and closing.