Download it now!
Bug 53531 - Time field in header not shown after FILEOPEN
Summary: Time field in header not shown after FILEOPEN
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.7.0 target:3.6.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-08-15 08:20 UTC by Dave
Modified: 2012-11-06 01:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2012-08-15 08:20:49 UTC
In the central area of a header for a spreadsheet I had included the date and time to record when the file was last modified.

In the view (Edit ... Headers & Footers), it appears as:
 00/00/0000   (00:00:00)

This worked fine in the previous version of Libre Office and in Open Office, but now after I close the file and open it again the view shows:
00/00/0000   (?)
Comment 1 Rainer Bielefeld Retired 2012-11-02 20:28:35 UTC
[Reproducible] with Server installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7175cee]" (tinderbox: Win-x86@6-fast, pull time 2012-05-16 22:07:37), I will do some further teests
Comment 2 Rainer Bielefeld Retired 2012-11-02 22:15:09 UTC
I tried with a document created with 3.5.7.2, where the time is shown after 
close / reopen. 3.6 does not show the time.

Was still ok with 3.6.0.0.alpha+ MinGW 2012-04-26 

@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 3 Kohei Yoshida 2012-11-02 23:50:35 UTC
This is my area.  I'll take this.
Comment 4 Kohei Yoshida 2012-11-06 01:01:18 UTC
Found the cause.  It was just a simple oversight and the fix is also equally simple.
Comment 5 Not Assigned 2012-11-06 01:08:46 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d84c6f8178dfebb618259f54409b4e67e7efe419

fdo#53531: Time field can be represented with an extended time field type.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2012-11-06 01:17:38 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2db9377f8505ca293054f8d5a8cc278159f117cb&g=libreoffice-3-6

fdo#53531: Time field can be represented with an extended time field type.


It will be available in LibreOffice 3.6.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Markus Mohrhard 2012-11-06 01:18:01 UTC
Marking as fixed.