Bug 53555 - SLIDESHOW: LibreOffice Impress crashes (segfault) on View Slide show (F5)
Summary: SLIDESHOW: LibreOffice Impress crashes (segfault) on View Slide show (F5)
Status: RESOLVED DUPLICATE of bug 56583
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.0.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-15 19:49 UTC by stucurtis15
Modified: 2014-02-10 21:18 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace output (28.28 KB, text/x-log)
2012-08-26 06:10 UTC, Simon
Details
Impress backtrace (5.21 KB, text/x-log)
2012-08-28 22:47 UTC, stucurtis15
Details
Impress backtrace (9.41 KB, text/plain)
2012-11-13 12:31 UTC, Roel van Meer
Details
Impress backtrace (8.37 KB, text/plain)
2013-08-15 22:31 UTC, Rudolf Cardinal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stucurtis15 2012-08-15 19:49:49 UTC
Starting slideshow either in dropdown menus or using F5 key causes LibreOffice to crash. Have tested new presentation or opening existing one.

dmesg reports "soffice.bin[1936]: segfault at 27ff000 ip 00007f2ff088086b sp 00007fff5e05c350 error 4 in libsdlo.so[7f2ff03d2000+6c1000]"


System info:
Linux Mint 13 (Maya) 64 bit.
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
Comment 1 Julien Nabet 2012-08-15 21:34:27 UTC
On pc Debian x86-64 with 3.6 branch updated today, I don't reproduce this problem.

Could you try again after having renamed your LO directory profile? (mv ~/.config/libreoffice ~/.config/libreoffice_backup)
Comment 2 Simon 2012-08-16 07:53:07 UTC
I seem to have same problem. Same steps as original poster, same symptoms. A common factor may be the Linux Mint distribution and (possibly) the MATE desktop environment.

I tried Julien's suggestion of moving the LO directory profile. Made no difference.

DMESG output after crash:
soffice.bin[11531]: segfault at 84 ip 00007f882a11386d sp 00007fff4faf5710 error 4 in libgdk-x11-2.0.so.0.2400.10[7f882a0a4000+ad000]

Also, running LO from command line "libreoffice3.6 --impress" has following terminal output after F5-induced crash:
(soffice:12918): Gdk-CRITICAL **: IA__gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed
(soffice:12918): Gdk-WARNING **: /build/buildd/gtk+2.0-2.24.10/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
(soffice:12918): Gdk-WARNING **: /build/buildd/gtk+2.0-2.24.10/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

System info:
1) LibreOffice Version 3.6.0.4 (Build ID: 932b512)
2) Linux 3.2.0-29-generic x86_64
3) Linux Mint 13 Maya, MATE desktop environment
Comment 3 Julien Nabet 2012-08-23 22:12:16 UTC
Could you try to retrieve an useful backtrace? (see http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29)
Did you try with another env than MATE?
Comment 4 Simon 2012-08-26 06:10:22 UTC
Created attachment 66124 [details]
Backtrace output
Comment 5 Simon 2012-08-26 06:17:51 UTC
Tried a few more things:
1) Reverted back to LO3.5.4 (default version in LM13 repo). Bug could not be reproduced in the earlier version.
2) Upgraded to LO version 3.6.0.2 from official LO ppa. Bug re-appeared.
3) Ran through instructions as per Julien's link. Backtrace output attached.

Also, I tried a fresh install of LM13-MATE on another partition with LO3.6.0.2. Could not reproduce bug in this environment.
Comment 6 Julien Nabet 2012-08-28 21:43:15 UTC
simon: thank you for your feedback, put it at NEW.
Comment 7 Simon 2012-08-28 22:02:23 UTC
@Julien - No worries. I'm happy to do more testing if required.
Comment 8 stucurtis15 2012-08-28 22:47:29 UTC
Created attachment 66250 [details]
Impress backtrace
Comment 9 stucurtis15 2012-08-28 22:48:34 UTC
I have also attached my backtrace. I have tried different login environments (Gnome Classic and Gnome classic (no effects)) with the same results
Comment 10 Julien Nabet 2012-08-29 05:54:58 UTC
simon, stucurtis: could you check if you lo-menubar installed? If yes could you uninstall it and test again?
Comment 11 Simon 2012-08-29 07:28:12 UTC
lo-menubar was not installed. Also, there was no change in behaviour after installing, and then again after removing or reinstalling it.
Comment 12 stucurtis15 2012-08-30 19:33:59 UTC
No, I don't have that extension installed either
Comment 13 jort.koopmans 2012-09-02 21:53:19 UTC
same bug here
Comment 14 Julien Nabet 2012-09-03 05:35:44 UTC
(In reply to comment #13)
> same bug here
With which distrib+version?
Comment 15 wat 2012-09-26 13:37:53 UTC
Same bug - no presentations will 'play'

Linux Mint 13 (64 bit): 3.2.0-31-generic 
Cinnamon 1.6

Libreoffice Version 3.6.0.1 (Build ID: 360m1(Build:101))

dmesg output:
soffice.bin[1588]: segfault at 29 ip 00007f876e53a840 sp 00007fffdf3783e8 error 4 in libtllo.so[7f876e4f7000+8c000]
Comment 16 John 2012-09-26 23:28:03 UTC
Also present in Ubuntu 12.04.1 LTS 
3.2.0-31-generic 64 bit

Same dmesg output...
This problem makes Impress useless as you are unable to show presentations.
Comment 17 Julien Nabet 2012-09-27 05:35:37 UTC
Thorsten: I couldn't reproduce this but several people could. Would you have some time to take a look?
Comment 18 Roel van Meer 2012-11-13 12:29:17 UTC
Same bug here.

Steps to reproduce:
- Start Impress
- Press F5

System info:
Slackware Linux 13.1 i486
LibreOffice version 3.6.3.2 (Build ID: 58f22d5)

dmesg says: soffice.bin[19551]: segfault at 50 ip b3375f2d sp bf9bb600 error 4 in libgdk-x11-2.0.so.0.1800.9[b3313000+90000]

Console output:

rolek@combineer:~$ /opt/libreoffice3.6/program/soffice

(soffice:21886): Gdk-CRITICAL **: gdk_window_get_origin: assertion `GDK_IS_WINDOW (window)' failed

(soffice:21886): Gdk-WARNING **: gdkdrawable-x11.c:952 drawable is not a pixmap or window

(soffice:21886): Gdk-WARNING **: gdkdrawable-x11.c:952 drawable is not a pixmap or window

Backtrace is attached. The main installer does not have the -dbg package though.
Comment 19 Roel van Meer 2012-11-13 12:31:14 UTC
Created attachment 70001 [details]
Impress backtrace

Backtrace of Impress crash, LibreOffice version 3.6.3.2 (Build ID: 58f22d5) on Slackware 13.1 i486
Comment 20 Julien Nabet 2012-11-14 18:53:15 UTC
Caolán: It's Impress so I thought about Thorsten according to http://wiki.documentfoundation.org/FindTheExpert but bts show vcl problem. Would you have some time to take a look?
I think I can't reproduce this because I don't have same gtk version I suppose.
Comment 21 Julien Nabet 2012-11-24 08:09:04 UTC
Just to know, what gtk versions are installed?
For example on pc Debian x86-64 testing updated today, I've got:
Source: gtk+2.0
Version: 2.24.10-2

I also got:
Package: libgtk-3-0
Source: gtk+3.0
Version: 3.4.2-4

If you don't have libgtk-3-0, could you install it and give a new try?

Caolán: it seems the same gdk_x11_window_set_user_time problem than https://bugs.freedesktop.org/show_bug.cgi?id=56583. Coincidence?
Comment 22 hugo 2013-02-15 18:52:45 UTC
same here

dmesg:
[15397.073492] soffice.bin[8353]: segfault at 78000000d1 ip 00007fecaa670248 sp 00007fff015f8d00 error 4 in libsfxlo.so[7fecaa32f000+49f000]
[15516.044007] soffice.bin[8402]: segfault at 8 ip 00007f6dbf204840 sp 00007ffff9e6de38 error 4 in libtllo.so[7f6dbf1c1000+8c000]

uname
Linux vaio 3.2.0-23-generic 

Mint 13 Cinnamon
Comment 23 Thorsten Behrens (CIB) 2013-02-19 18:30:36 UTC
Most of the backtraces end up in lcl_set_user_time() in the gtk3 backend - are you using distro builds, or vanilla TDF ones? And does the bug persist if you do an

export SAL_USE_VCLPLUGIN=gtk in a shell before starting soffice from there?
Comment 24 Rudolf Cardinal 2013-08-15 22:31:56 UTC
Created attachment 84114 [details]
Impress backtrace

after: export SAL_USE_VCLPLUGIN=gtk
Comment 25 Rudolf Cardinal 2013-08-15 22:44:41 UTC
The backtrace above is from LibreOffice Impress crashing upon F5. It was working fine until today; then it started crashing instantly upon F5 even if the presentation was a newly-created blank one.

This is after: export SAL_USE_VCLPLUGIN=gtk (as suggested)

OS: Linux wombat 3.2.0-49-generic-pae #75-Ubuntu SMP Tue Jun 18 18:00:21 UTC 2013 i686 i686 i386 GNU/Linux

LibreOffice PPA: http://ppa.launchpad.net/libreoffice/libreoffice-4-0/ubuntu precise main

libreoffice package: Version: 1:4.0.4~rc2-0ubuntu1~precise1

xfce version: 4.8.0.3 (with a two-monitor configuration)

NOT fixed by renaming away ~/.config/libreoffice

libgtk-3-0 version: 3.4.2-0ubuntu0.5
Comment 26 Thorsten Behrens (CIB) 2013-08-16 08:29:01 UTC
Looks actually like a duplicate to bug 56583 then - can you try 4.0.5 RC1, that has it fixed, available here: http://www.libreoffice.org/download/pre-releases/ ?
Comment 27 Caolán McNamara 2013-11-05 16:22:29 UTC

*** This bug has been marked as a duplicate of bug 56583 ***
Comment 28 ffs 2013-11-24 15:38:07 UTC
Not sure if this is related but I get crashes with impress giving a similar error around once per day but seemingly at random - not associated with F5

soffice.bin[6872]: segfault at 0 ip 00007eff9584f1e0 s00007fff93c5c740 error 4 in libsdlo.so[7eff955aa000+65a000]

soffice.bin[13368]: segfault at 0 ip 00007f01966131e0 sp 00007fff5ce8da70 error 4 in libsdlo.so[7f019636e000+65a000]

It seems to happen at random - there is a long freeze followed by a crash

I'm running nvidia twinview
Comment 29 retired 2013-11-24 15:56:48 UTC
Can you please provide a test document so this can be tested against and subsequently be confirmed. If your document contains sensitive data, please clear that or replace it with random information.

A step-by-step description of how to reproduce the issue is most helpful and will help to speed up the processing of this problem a lot.

Does the problem persist with LO 4.1.3.2?

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 30 Björn Michaelsen 2014-01-17 11:08:46 UTC
(This is an automated message.)

This bug is not a MAB and in NEEDINFO, thus gradually adjusting priority to high. Please see the QA mailing list or the ESC call minutes for details.
Comment 31 Julien Nabet 2014-02-10 21:18:02 UTC
ffs: I don't know if you still have these random bts with newer LO versions (last ones are 4.1.4 and 4.2.0). If it's the case, please submit a new bugreport since it's not sure at all it's the same problem.
For the moment, I put back this one to RESOLVED/DUPLICATE

*** This bug has been marked as a duplicate of bug 56583 ***