Download it now!
Bug 53704 - EDITING: Locks on first edit
Summary: EDITING: Locks on first edit
Status: RESOLVED DUPLICATE of bug 46609
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-19 10:19 UTC by fenglich
Modified: 2012-09-28 08:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fenglich 2012-08-19 10:19:45 UTC
Problem description: 

When doing the first edit in a new document, Libre Office locks up for a number of seconds, causing the busy wheel to occur. It's annoying and reminds of buginess each time one use Libre Office.

Perhaps this bug is specific to OS X. Perhaps it's some form of resources that are initialized (such as perhaps plugins loaded from disk), that causes this. I would try to do it asynchronously with low priority and no matter what do it as early as possible. Even if it cannot be done asynchronously I would do it at the beginning of opening the document. Better it occurs then rather than when the user tries to work. 

Steps to reproduce:
1. Start Libre office
2. Open a new text document
3. Do any form of editing in the document, such as type on letter.
4. Libre Office will lock up so long that OS X busy wheel occurs.

Current behavior:

Expected behavior:

Platform (if different from the browser): 

A 2011 Macbook Pro. That should be sufficient.           

Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_0) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.79 Safari/537.1
Comment 1 Roman Eisele 2012-09-28 08:26:58 UTC
Thank you very much for your bug report,
especially for the careful and detailed description!

This is the same issue as in bug 46609, therefore I mark your bug report as a duplicate of the latter. However, I will copy your parts of your report to bug 46609 (which is missing a good description until now).

So thank you again! All further discussion (if necessary) should take place in the report for bug 46609.

*** This bug has been marked as a duplicate of bug 46609 ***