Bug Hunting Session
Bug 53717 - VIEWING: EPS Objects on transparent background WRITER shows WHITE.
Summary: VIEWING: EPS Objects on transparent background WRITER shows WHITE.
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-19 15:00 UTC by C.Berlin
Modified: 2015-03-21 17:40 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
EPS Example, ODT Writer, PDF Export, Screenshot (337.77 KB, application/x-gzip)
2012-08-19 15:00 UTC, C.Berlin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description C.Berlin 2012-08-19 15:00:02 UTC
Created attachment 65781 [details]
EPS Example, ODT Writer, PDF Export, Screenshot

Problem description: 

Steps to reproduce:
1. Take an EPS and set the background to transparent (Inkscape coud do the job) 
2. Open Writer and set the Background Color to non-white Color
3. Import the EPS graphic and you will see the graphic on a withe background

Current behavior:

EPS with graphics on transparent background shows white.

Expected behavior:

EPS with graphics on transparent background should be shown the background color of the current page.


Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 Thomas Hackert 2013-06-25 17:18:34 UTC
Hello C. Berlin, *,
I can confirm your issue with LO Version: 4.1.0.1 Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155 with installed Germanophone lang- as well as helppack under Debian Testing AMD64, so I set the status to "New". Maybe some kind developer will have a look at it ... ;)
Sorry for the inconvenience
Thomas.
Comment 2 QA Administrators 2015-03-16 22:54:30 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

    Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
    https://www.libreoffice.org/download/

    If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
  
  If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

    Update the version field
    Reply via email (please reply directly on the bug tracker)
    Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-03-16
Comment 3 Jean-Baptiste Faure 2015-03-21 17:40:13 UTC
Several points here:
1/ how do you check that your EPS file has transparent background?
2/ what you see in the LibreOffice and what is exported to PDF is the preview of the EPS. As your EPS does not include a preview (raster image), it is generated on the fly by LibreOffice using an external program if available (ghostscript under Linux). Not sure if this program has the capability to generate a preview with transparency.

That said, in the cases where transparency background is important, you should use SVG format instead of EPS. Your test file shows that it works as expected with SVG.

So if there is a bug it is not a bug in LibreOffice. So closing as NotOurBug.
Please, feel free to reopen if you disagree.

Best regards. JBF