Download it now!
Bug 53817 - Not asking for saving changing when only active tab is changed
Summary: Not asking for saving changing when only active tab is changed
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-19 20:27 UTC by Grobe
Modified: 2013-11-16 12:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Libre Office will ask to save this document, even if it should not ask (31.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-02-18 17:12 UTC, Grobe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grobe 2012-08-19 20:27:40 UTC
Hi.

Whenever I open a spreadsheet file and the only thing I do is to look at other sheets than the active just after opening the file.

That makes Calc asking to save the file, even if no data is actually changed (other that the avtive sheet is changed).

There should be an option somewhere that gives the user a choice to not ask for saving the file if only active tab or active cell is changed.
But it should still be possible to manually save a spreadsheet without any actually data is changed, when active cell/sheet is changed.


Thanks
Comment 1 A (Andy) 2013-02-16 19:12:20 UTC
not reproducible with LO 4.0.0.3 (Win7 Home, 64bit)

@Grobe: Can you still reproduce this behavior with the latest release of LO?

Can anybody else confirm this behavior?
Comment 2 Grobe 2013-02-18 17:12:46 UTC
Created attachment 75061 [details]
Libre Office will ask to save this document, even if it should not ask
Comment 3 Grobe 2013-02-18 17:27:53 UTC
Yes it does, but only to some files that have a long "history of changes", espechially if created with older versions of LibO.

I upload one file that I have made empty.

[off topic]
You guys running this site should change the "add attachment" function. It is indeed very dangerous to click on the "add attachment" link because it did erase the whole comment that I wrote.
I elaborated a lot more than I wroted just above, but that is just gone now.

I've never seen any other forum or bug repport site that ERASE the comment field when I try to upload a file attachment.
Comment 4 A (Andy) 2013-02-23 12:10:58 UTC
@Grobe: Thank you very much for your fast response and the test file.  I have tested it with this file, but unfortunately I cannot reproduce it.  Everything seems to be OK with this file.

Can anybody else confirm this bug?
Comment 5 Joel Madero 2013-06-28 01:30:46 UTC
This is actually intended because most people want their document to open where it left off - adding an option just for this one thing isn't going to happen as we try to keep our options to a minimum.

Marking as NOTABUG - behaves as expected

as for Comment 3 - FDO is not our infra but I'll try to report a bug for their infra team