Bug 53847 - Ability to forbid the use of direct formatting
Summary: Ability to forbid the use of direct formatting
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:6.4.0
Keywords: needsUXEval
Depends on: 107865
Blocks: Writer-Styles UI
  Show dependency treegraph
 
Reported: 2012-08-20 14:52 UTC by Rodrigue Villetard
Modified: 2019-08-24 23:35 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rodrigue Villetard 2012-08-20 14:52:49 UTC
Problem description: 

Ad educational purposes, I would like to deactivate all direct formatting option. Do everyhing withe styles.


Current behavior:

it's not possible

Expected behavior:

Add an option to disable all direct formatting stuff

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1


Note : I would totally understand that it is not a high priority work ;D
Comment 1 A (Andy) 2013-02-16 19:19:35 UTC Comment hidden (obsolete)
Comment 2 Thomas Lendo 2018-10-08 23:08:04 UTC
From my OOo bug report:
In all documentations and guides it is highly recommended that you use paragraph styles rather than manually formatting paragraphs. So, an option would be a good feature that removes all manually formatting paragraphs from the graphical user interface (menus, toolbars, dialogs) that have a "soft formatting" counterpart. This option should be easy to activate and deactivate at any time.

Benefit for the user
* is a tidier user interface and
* he/she would not be distracted anymore with hard formatting buttons.
Comment 3 V Stuart Foote 2019-07-31 12:27:26 UTC
Seems to me would be fertile ground as a MUFFIN offering. Suppressing the DF toolbars for their Style based counterparts supplementing with NB and SideBar to get UI reduced to expose just the style based tools. Some subset of well known DF shortcuts would need to be suppressed (e.g. Main menu entries on the Format -> Text)

But configuring the UI to emphasize style based editing, suppressing DF, would be worth pursuing.
Comment 4 Heiko Tietze 2019-07-31 18:20:13 UTC
Yes to the MUFFIN approach but I wouldn't add this variant to the program but share as extension. So my take is WF (keeping it open for more opinions).
Comment 5 Thomas Lendo 2019-07-31 22:22:51 UTC
I feel that bug 107865 (UNO commands to modify style-level character and paragraph properties) and maybe other bugs of bug 117022 ([META] Style-focused formatting toolbar) are necessary to fulfill this request.

See also Mike's ststement in bug 107865 comment 9.
Comment 6 Heiko Tietze 2019-08-15 09:16:10 UTC
We discussed the topic in the design meeting. With the introduction of a styles focused toolbar (bug 106781) the request is done. You have to manually disable the Formatting toolbar and enable Formatting (Styles). As an addition I'll hide the few direct formatting commands.
Comment 7 Commit Notification 2019-08-15 13:46:39 UTC
Heiko Tietze committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/55291868dd1b73d2ba4ec2aa75889e10377d5bef%5E%21

tdf#53847 - Styles focused toolbar

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Thomas Lendo 2019-08-15 22:02:40 UTC
Heiko, why have you changed the summary 'Ability to forbid the use of direct formatting' to a new one that only covers a subset of a what was meant originally? As far as I understand this issue isn't about the style formatting toolbar. It means menus, Toolbars, sidebar, context menus.

I like the original idea, also Stuart likes it, so we should it reopen to work out a plan for it's realisation.

Also I'm not a fan of your changes in the style formatting toolbar. Jay and me discussed the buttons long and detailed. As long as there are some bugs open (e.g. bug 107865) to bring the full power of styles (outside of the styles settings dialog) to the user, we must accept some DF commands to make sure that this styles formatting toolbar is usable today. The new changes doesn't help to bridge the time gap to the bright styles future.
Comment 9 Cor Nouws 2019-08-16 10:17:40 UTC
Hi Thomas,

(In reply to Thomas Lendo from comment #8)
> Heiko, why have you changed the summary 'Ability to forbid the use of direct
> formatting' to a new one that only covers a subset of a what was meant
> originally? As far as I understand this issue isn't about the style
> formatting toolbar. It means menus, Toolbars, sidebar, context menus.
That is true.
Maybe we were lazy, and in absence of concrete proposals, the hint of Stuart for a special Muffin bar and then realizing we already had one special toolbar, and then realizing it was "Styles +" ;) - so a four-step shortcut to where we are now.

Probably I've been able to hide that I'm a fan of using styles, so let me be clear: if there is a good realistic proposal, I'll support it :)
Comment 10 Heiko Tietze 2019-08-16 11:22:07 UTC
(In reply to Thomas Lendo from comment #8)
> I like the original idea, also Stuart likes it, so we should it reopen to
> work out a plan for it's realisation.

Feel free to reopen though I think it's solved. We will not MUFFIN-ize the sidebar neither it's a good idea to hide commands in the main menu (which would be possible right now). Font/Background color are worth a dedicated style so remvoing them from the special toolbar makes sense to me. 
However I don't want to block and will revert the patch if you think so. And feel free to reopen any ticket I close.
Comment 11 Thomas Lendo 2019-08-24 23:34:33 UTC
Heiko, I ask you to revert your changes in the styles formatting toolbar unless these changes were discussed in detail. These changes haven't anything to do with this bug report.

I want to come back to the original idea of this bug report, therefore I reverted the summary and reopened the bug.

If this idea isn't desired at all (Heiko said that commands shouldn't be hidden e.g. in the main menu) then this bug should be closed as Wontfix.

In my view, without bug 107865 being fixed nothing can't be done for this bug because most of the formatting commands must be hidden to show only style commands. This wouldn't be helpful when there is nothing to click anymore. ;-) But suppressing DF toolbars and the DF sidebar decks (not the style sidebar deck) must also be included. It could be activated with a new item in the menu View > User Interface.