Download it now!
Bug 53854 - FILESAVE: LO 3.6.0 corrupts Base database document file
Summary: FILESAVE: LO 3.6.0 corrupts Base database document file
Status: RESOLVED DUPLICATE of bug 52639
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) Linux (All)
: highest blocker
Assignee: Lionel Elie Mamane
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-08-20 18:15 UTC by Dan Lewis
Modified: 2012-08-21 08:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The corrupted database file (1.96 MB, application/vnd.sun.xml.base)
2012-08-20 18:15 UTC, Dan Lewis
Details
A Copy made of Budget.odb before opening the original with LO 3.6.0. (1.96 MB, application/vnd.sun.xml.base)
2012-08-20 18:19 UTC, Dan Lewis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Lewis 2012-08-20 18:15:19 UTC
Created attachment 65840 [details]
The corrupted database file

Problem description: 
When working with a Base database using LO 3.6.0.4, after saving the file and closing Base, the file can not be opened again.
Steps to reproduce:
1. Open a database document file.
2. Modify a table, create another table, etc.
3. Save the Base file.
4. Open the Base file.

Current behavior:
After working with a database document file with LO 3.6.0.4, saving the file corrupts it. When attempting to open the file, I get the Filter Selection dialog. This is true for LO 3.4.6, LO 3.5.6, and AOO 3.4.1.
Expected behavior:
The file should open 
Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:14.0) Gecko/20120715 SeaMonkey/2.11
Comment 1 Dan Lewis 2012-08-20 18:19:59 UTC
Created attachment 65841 [details]
A Copy made of Budget.odb before opening the original with LO 3.6.0.
Comment 2 Alex Thurgood 2012-08-21 06:57:33 UTC
Dan,

I can reproduce this on Linux 64bit 3.6.0.4, but it is/was also being discussed on the German user/discuss mailing list, and I don't know now whether they actually filed a bug report, so this might be a duplicate.


Alex
Comment 3 Alex Thurgood 2012-08-21 07:00:37 UTC
@Robert : did you or anyone else from the German list file a bug report in the end for this problem ?


Alex
Comment 4 Alex Thurgood 2012-08-21 07:03:28 UTC
Hi Lionel,

From what I understand, this bug only affects x64 bit version, but for some reason when an existing ODB file is opened in Base, it gets truncated on saving, and thereby becomes unopenable in any version of LO, AOOo or equivalent products.


Alex
Comment 5 Lionel Elie Mamane 2012-08-21 07:23:02 UTC
Please check whether this is or not a duplicate of bug 52639. For example, check with a recent daily or 3.6.1.rc
Comment 6 Alex Thurgood 2012-08-21 08:56:40 UTC
(In reply to comment #5)
> Please check whether this is or not a duplicate of bug 52639. For example,
> check with a recent daily or 3.6.1.rc

Thanks Lionel, that's the one, but of course, I forgot to look for resolved bugs in my hunt for the dup.


Setting as duplicate.

Alex

*** This bug has been marked as a duplicate of bug 52639 ***