Download it now!
Bug 53994 - Calc EDITING: natural sorting not working
Summary: Calc EDITING: natural sorting not working
Status: RESOLVED DUPLICATE of bug 53482
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Noel Power
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-08-24 08:20 UTC by sasha.libreoffice
Modified: 2012-09-05 05:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-08-24 08:20:05 UTC
Beginning from version 3.6.0.4 in Calc present this regression:
Natural sorting not works

Steps to reproduce:
0. Start Calc
1. Enter in first column these numbers:

1
11
2

2. Select rows with numbers and Data->Sort, tab "Options", option "Enable natural sort", press "OK".
Expected: numbers will 1,2,11
Actually: nothing happens
Not reproduced in 3.5.5, therefore regression
Tested on Fedora 64 bit
Comment 1 Markus Mohrhard 2012-08-24 19:40:11 UTC
Ok, will try to have a look at this one soon.
Comment 2 Markus Mohrhard 2012-08-28 23:23:35 UTC
I can't reproduce this one with my own build. Can someone please confirm this and/or provide me with a test document showing the problem.
Comment 3 Jean-Baptiste Faure 2012-08-29 05:15:41 UTC
(In reply to comment #0)
[...]
> 2. Select rows with numbers and Data->Sort, tab "Options", option "Enable
> natural sort", press "OK".

Yes, you need to go back to the tab Sort criteria before clicking OK button.
In tab "Options" OK button seems to only validate the options, it does not trigger the sorting.

Best regards. JBF
Comment 4 Noel Power 2012-08-30 08:34:07 UTC
I'll try and have a look
Comment 5 Markus Mohrhard 2012-08-30 10:12:12 UTC
@Noel: Albert who wrote the new dialog is already looking into a similar problem. They might be relate.
Comment 6 Markus Mohrhard 2012-08-30 10:16:53 UTC
See Bug 53482 but I have no idea if they are related.
Comment 7 Noel Power 2012-08-30 20:20:08 UTC
this is a duplicate

*** This bug has been marked as a duplicate of bug 53482 ***
Comment 8 Albert Thuswaldner 2012-09-04 18:37:32 UTC
This bug does not persist in current master. Can somebody check 3.6.1?
Comment 9 Albert Thuswaldner 2012-09-04 19:00:58 UTC
Works for  me in 3.6.1.2
Comment 10 sasha.libreoffice 2012-09-05 05:25:49 UTC
reproduced in 3.6.1.2 (Build ID: e29a214) on Fedora 64 bit