Bug Hunting Session
Bug 54009 - Jumplists not working - cannot pin open document formatted docs (.ods, odt)
Summary: Jumplists not working - cannot pin open document formatted docs (.ods, odt)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All Windows (All)
: medium trivial
Assignee: Jesus Corrius
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-24 14:01 UTC by brad
Modified: 2014-10-08 12:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brad 2012-08-24 14:01:56 UTC
Windows 7 professional, 32bit

I can pin some items to the jumplist but not all.  I believe the one document in question was created in OpenOffice.  Also, recent items in the jumplist is missing.
Comment 1 bfoman (inactive) 2012-08-24 22:23:16 UTC
See Bug 50913 and Bug 53019.
Comment 2 brad 2012-08-28 21:18:36 UTC
I have discovered that it's the open document format that will not pin the to taskbar.  I can pin spreadsheets that are in the .xls format but not any in the .ods format.
Comment 3 brad 2012-08-30 17:37:37 UTC
Just upgraded to 3.6.1.  Still seeing the same behavior which is NOT like the bug reports you referenced.

I can pin any LibreOffice application to the taskbar.  I can pin any Microsoft Office formatted document to a LibreOffice program jumplist (.doc, .xls, etc.).  I CANNOT pin an Open Document fomatted document to any LibreOffice program jumplist (.odt, .ods, etc.).

(In reply to comment #1)
> See Bug 50913 and Bug 53019.
Comment 4 Jacob Share 2012-09-07 11:03:49 UTC
I'm on Win7 Home Premium, 64-bit.

I can confirm brad@themcclaves.com comments- e.g. for scalc, I can pin .xlsx files but not .ods files.

Also, I wanted to point out that I have Recent Items enabled in Win7, but they don't appear in the e.g. scalc jumplist. You only see the pinned items, the generic shortcut to LibreOffice Calc, and 'unpin this program from the taskbar'.
Comment 5 gioni 2012-09-12 08:08:41 UTC
I'm on Win7 Home Premium, 64-bit.
Still seeing the same behavior of second point of JACOB. Also I noticed that 
I can pin .ods files only in the jump list of new calc temporary icon file just opened.
Comment 6 brad 2012-10-12 18:37:30 UTC
Just upgraded to LO 3.6.2.2 but before I did so I uninstalled the old version and removed all remnants.  I am still seeing the same issue, can only pin MS Office documents (.xls, .doc) but cannot pin open document formatted docs (.ods, odt).
Comment 7 bfoman (inactive) 2012-10-18 11:58:59 UTC
Extended Summary.

@brad: did you notice behavior like in bug 56125?
Comment 8 brad 2012-11-08 18:37:46 UTC
Similar not not entirely like in that bug report.  Also, if I am to understand how the numbering works with bugs, they are sequential which would mean that bug was submitted long after this one was.  Is it possible to combine the two or close one in favor of the other?
Comment 9 brad 2012-11-08 18:58:32 UTC
Just upgraded to 3.6.3.  Exact same problem.
Comment 10 gioni 2012-12-03 08:56:20 UTC
Just upgraded to 3.6.3. Problem still exist.
Note: I have pinned writer, calc icons but recent files are missing. Only after writer or calc are being started then a recent list appears in the application icon. But if both writer and calc are launched, the recent list appear only on the first application has been launched.
Comment 11 bfoman (inactive) 2012-12-03 12:26:10 UTC
Changed Version field back. Please do not change it as this is an indication with what version the problem appeared.
If a problem is still reproduced in newer version - please write an additional comment only.
Comment 12 brad 2012-12-31 17:11:00 UTC
Problem still exists in 3.6.4
Comment 13 Bates83 2013-01-24 21:50:58 UTC
Same problem here since 3.60. Can't understand that no developer recognized this issue while using LibreOffice, because it hits the regular usage: starting it! The whole icon-thing behaves wired.
Comment 14 brad 2013-01-30 20:04:27 UTC
I've figured out a solution to the problem. I tried to make this work on a brand new computer and low & behold it did!  On the original computer I used Revo Uninstaller to completely remove LibreOffice and any trace of the program after which I re-installed.  Works perfectly.  Something in the left over registry entries or files is what causes this problem.
Comment 15 brad 2013-01-30 20:16:20 UTC
Looks like I jumped the gun, it's still not working.  What happened was I tried to pin a .ods document which worked.  Then I tried .xls files which also worked.  When I tried another .ods document, it failed just as it always does but .xls documents continue to work so it looks like .xls documents are cock-blocking the .ods file from being pinned somehow.
Comment 16 brad 2013-01-30 20:24:07 UTC
Tried this on another machine it it's exactly the opposite.  Can pin .ods files but not .xls files.  It seems once you pin one file type, it blocks all others from being pinned.
Comment 17 gmvolk 2013-03-15 14:17:23 UTC
This same bug appears in the 4.0 version.  Found a partial workaround.  Pin the LO program to your start menu, then pin the document you want to the start menu.  Open up the jump list for the program and then drag and drop you pinned document to the jump list.  You can remove the document from the stat menu jumplist, and pin the LO program to the taskbar.  Jumplists and recent items are now available on the taskbar pinned LO program.
Comment 18 bfoman (inactive) 2013-03-15 15:16:50 UTC
Please do not change the version field as it indicates the first version where the bug occurred.
Comment 19 Jesus Corrius 2013-07-25 15:55:12 UTC
This problem will be fixed in LibreOffice 4.1.1.
Comment 20 Jesus Corrius 2013-07-30 10:56:07 UTC
Let's close it as RESOLVED FIXED. We will reopen it if we find any regression during the testing process of LibreOffice 4.1.1.
Comment 21 brad 2013-09-03 12:13:56 UTC
Confirmed.  Pinning is now working as is should using version 4.1.1.2.

Thank you!!!!!!!
Comment 22 Oliver 2014-10-08 12:58:21 UTC
does not seem to have been fixed in 4.3.0.4 
see https://www.libreoffice.org/bugzilla/show_bug.cgi?id=45600#c28