Download it now!
Bug 54036 (kwatson703) - EDITING: Sorting function incomplete
Summary: EDITING: Sorting function incomplete
Status: RESOLVED WORKSFORME
Alias: kwatson703
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-25 03:08 UTC by Ken Watson
Modified: 2014-10-14 21:07 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ken Watson 2012-08-25 03:08:34 UTC
Problem description: 
Nothing happens when trying to sort data by columns from the Data --> Sort menu.  Sorting works using the autosort icon in the toolbar, but options (such as "Range contains column labels") are not available.

Steps to reproduce (part 1 of problem):
1. Highlight a column header (A, B, etc.)
2. Select Data --> Sort --> Extend Selection --> Options tab, Range contains column labels.
3. Click OK.

Current behavior:
Nothing happens

Expected behavior:
Data should sort alphabetically

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

Steps to reproduce (part 2 of problem):
1. Highlight a column header (A, B, etc.)
2. Select "Sort Ascending" icon in toolbar
3. Select "Extend selection"

Current behavior:
Data sorts, but if there are any column headers, they are sorted into the column. After sorting, a new first row must be created, the column headers copied back into that row, and the extra header row deleted.

Expected behavior:
There should be an option tab that appears after the "Extend selection" window.

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Comment 1 billhook 2012-08-26 08:19:24 UTC
What is "Extend Selection"?
Comment 2 Ken Watson 2012-08-26 12:40:38 UTC
(In reply to comment #1)
> What is "Extend Selection"?

Sorting data in a spreadsheet, if you highlight one column and then select Sort (either through the menu: Data --> Sort or the quick sort icon in the toolbar), a window pops up giving you three options: Extend selection, Current selection, or Cancel. If you select "Extend selection" the highlighted sort area will extend to all the data on the sheet. If you select "Current selection" only the data in the selected column will be sorted. Normally, users need to sort all the data using one (or more) columns as the sort order.
Comment 3 billhook 2012-08-26 19:03:06 UTC
I could reproduce your first test case, but not reliably. It seems to work after the first time? I only saw the sort do "nothing" twice. If I then tried again it would work.

Does the problem happen every time for you? Perhaps attach a sample spreadsheet.
Comment 4 Ken Watson 2012-08-26 19:28:57 UTC
(In reply to comment #3)
> I could reproduce your first test case, but not reliably. It seems to work
> after the first time? I only saw the sort do "nothing" twice. If I then tried
> again it would work.
> 
> Does the problem happen every time for you? Perhaps attach a sample
> spreadsheet.

It happened every time. I need this function very frequently, so I have reverted to LibreOffice 3.5.6.2 for now.
Comment 5 Ken Watson 2012-11-03 00:33:36 UTC
I installed v3.6.3.2 and this problem is no longer present.  Thanks!
Comment 6 Jean-Baptiste Faure 2014-10-14 21:07:37 UTC
Correct status is WorksForMe because we don't know which commit fixed the problem.

Best regards. JBF