Download it now!
Bug 54087 - Firefox plugin not recognized in LibO 3.6 (regression)
Summary: Firefox plugin not recognized in LibO 3.6 (regression)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:4.1.0 target:4.0.4 target:3.6.7
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-08-26 15:59 UTC by Frank Fuchs
Modified: 2013-05-06 12:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Fuchs 2012-08-26 15:59:44 UTC
In LibreOffice 3.6 (including 3.6.1.2), the Firefox plugin is not recognized by the browser (and not listed under Firefox-Tools-AddOns). This is a regression from 3.5.x
Comment 1 jmpierre 2012-11-29 13:48:48 UTC
In LibreOffice 3.6 (including 3.6.3.2), the Firefox plugin is not recognized
Comment 2 Stephan Bergmann 2012-11-29 15:10:21 UTC
This should be fixed with git commit 771a18c31b6b156d194acc422f5dead9f89d378b "Enable NPP_Initialize/Shutdown again" in LibreOffice 3.6.4.
Comment 3 Frank Fuchs 2012-12-01 20:11:04 UTC
(In reply to comment #2)
> This should be fixed with git commit
> 771a18c31b6b156d194acc422f5dead9f89d378b "Enable NPP_Initialize/Shutdown
> again" in LibreOffice 3.6.4.

Can you please re-test: In today's installation of LO 3.6.4.3 (3.6.4 RC3), Firefox 17.0.1 still does not show the LO plugin.
Comment 4 Stephan Bergmann 2012-12-03 08:39:53 UTC
(In reply to comment #3)
> Can you please re-test: In today's installation of LO 3.6.4.3 (3.6.4 RC3),
> Firefox 17.0.1 still does not show the LO plugin.

Tested with <http://download.documentfoundation.org/libreoffice/testing/3.6.4/rpm/x86_64/LibO_3.6.4.3_Linux_x86-64_install-rpm_en-US.tar.gz> (as currently available at <https://www.libreoffice.org/download/pre-releases/>) on x86-64 Fedora 17:  Start /opt/libreoffice3.6/program/soffice, select "Tools - Options... - Internet - Browser Plug-in - Display documents in browser", quit LO, notice symlink ~/.mozilla/plugins/libnpsoplugin.so -> /opt/libreoffice3.6/program/libnpsoplugin.so, start firefox (Firefox 17.0 coming with Fedora 17), about:plugins shows the LibreOffice Plug-In, and opening a file:///...odt URL opens the LO-backed document in the browser.
Comment 5 Frank Fuchs 2012-12-03 09:15:42 UTC
(In reply to comment #4)
> (In reply to comment #3)
> > Can you please re-test: In today's installation of LO 3.6.4.3 (3.6.4 RC3),
> > Firefox 17.0.1 still does not show the LO plugin.
> 
> Tested with
> <http://download.documentfoundation.org/libreoffice/testing/3.6.4/rpm/x86_64/
> LibO_3.6.4.3_Linux_x86-64_install-rpm_en-US.tar.gz> (as currently available
> at <https://www.libreoffice.org/download/pre-releases/>) on x86-64 Fedora
> 17:  Start /opt/libreoffice3.6/program/soffice, select "Tools - Options... -
> Internet - Browser Plug-in - Display documents in browser", quit LO, notice
> symlink ~/.mozilla/plugins/libnpsoplugin.so ->
> /opt/libreoffice3.6/program/libnpsoplugin.so, start firefox (Firefox 17.0
> coming with Fedora 17), about:plugins shows the LibreOffice Plug-In, and
> opening a file:///...odt URL opens the LO-backed document in the browser.

Under Windows, this doesn't seem to work:
- first of all (this may be really minor): If you enable the option in LO to "display documents in browser", LO "loses" this information, i.e. if you close and re-start LO, you have to set this option again. Even if you do not close LO, but re-open the option dialog, the checkbox is not set.
- secondly, under Windows, FF does not open an LO file (tested with an .ods file) and the plugins directory of FF does not show the LO plugin. In fact, when I search the LO installation directory, I cannot find the LO plugin. Can it be that there is a bug that it is not shipped with LO 3.6.4.3 ?
Comment 6 Stephan Bergmann 2012-12-03 11:05:32 UTC
(In reply to comment #5)
> Under Windows, this doesn't seem to work:
> - first of all (this may be really minor): If you enable the option in LO to
> "display documents in browser", LO "loses" this information, i.e. if you
> close and re-start LO, you have to set this option again. Even if you do not
> close LO, but re-open the option dialog, the checkbox is not set.
> - secondly, under Windows, FF does not open an LO file (tested with an .ods
> file) and the plugins directory of FF does not show the LO plugin. In fact,
> when I search the LO installation directory, I cannot find the LO plugin.
> Can it be that there is a bug that it is not shipped with LO 3.6.4.3 ?

Yes, looks like <http://download.documentfoundation.org/libreoffice/testing/3.6.4/win/x86/LibO_3.6.4.3_Win_x86_install_multi.msi> (as currently available at <https://www.libreoffice.org/download/pre-releases/>) lacks the npsoplugin.

Fridrich, could it be that that installset was built with --disable-nsplugin (and a cursory glance at the source code makes it look like "Tools - Options... - Internet - Browser Plug-in" would nevertheless be present indeed, at least on Windows)?
Comment 7 Frank Fuchs 2012-12-07 10:50:52 UTC
- Install package is missing plugin (see message from Stephan)
- Options dialog loses information that browser plugin is enabled (see my message)
Comment 8 Stephan Bergmann 2012-12-07 11:24:29 UTC
(In reply to comment #7)
> - Install package is missing plugin (see message from Stephan)
> - Options dialog loses information that browser plugin is enabled (see my
> message)

Whenever you open the "Browser Plug-in" options, it computes whether to check-mark "Display documents in browser" based on whether the plugin is present in the Mozilla plugin directory, so the latter is a consequence of the former.
Comment 9 gnkaras 2013-02-05 08:32:41 UTC
(In reply to comment #8)
> Whenever you open the "Browser Plug-in" options, it computes whether to
> check-mark "Display documents in browser" based on whether the plugin is
> present in the Mozilla plugin directory, so the latter is a consequence of
> the former.

Thanks for explaining that!  I can confirm that this issue remains in the 3.6.5.2 release, at least on Windows.  (Windows 8 x64)
Comment 10 Stephan Bergmann 2013-02-05 09:10:04 UTC
(In reply to comment #6)
> (In reply to comment #5)
> Yes, looks like
> <http://download.documentfoundation.org/libreoffice/testing/3.6.4/win/x86/
> LibO_3.6.4.3_Win_x86_install_multi.msi> (as currently available at
> <https://www.libreoffice.org/download/pre-releases/>) lacks the npsoplugin.
> 
> Fridrich, could it be that that installset was built with --disable-nsplugin
> (and a cursory glance at the source code makes it look like "Tools -
> Options... - Internet - Browser Plug-in" would nevertheless be present
> indeed, at least on Windows)?

Fridrich, András, Petr, can any of you pick this up?
Comment 11 Petr Mladek 2013-02-06 13:53:40 UTC
Hmm, the plugin depends on GTK and it has been explicitly disabled on Windows, see http://cgit.freedesktop.org/libreoffice/core/commit/?id=4fed2075cc3ae3857485cf5f370ad7717e823be4

Andras, do you remember why you disabled GTK?
Comment 12 Hüseyin Kozan 2013-02-20 10:18:32 UTC
Not working with LO 4.0 and FF 19 on Windows 8. 
Settings needs admin rights to enable.
Comment 13 Andras Timar 2013-02-20 11:04:41 UTC
(In reply to comment #11)
> Andras, do you remember why you disabled GTK?

Because someone simplified configure, and as side affect, GNOME desktop integration module appeared in the Windows installer. I was told that GTK was used on Linux only, so I disabled it for Windows and Mac.
Comment 14 Not Assigned 2013-02-22 11:24:39 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b4a89972cb6a6370224d5de3b88f9e642f93624a

fdo#54087 build npsoplugin on Windows, it does not depend on GTK+ there



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Not Assigned 2013-02-24 13:22:26 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=61d371f9de3fc05d1e537ede87bac498f484af19&h=libreoffice-3-6

fdo#54087 build npsoplugin on Windows, it does not depend on GTK+ there


It will be available in LibreOffice 3.6.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Not Assigned 2013-02-25 11:42:41 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=90ef7668265e7187d61842ec8950aa91770a53da&h=libreoffice-4-0

fdo#54087 build npsoplugin on Windows, it does not depend on GTK+ there


It will be available in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Not Assigned 2013-02-25 13:58:47 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=18144fcba27a408635ae266cd97f11cfb5a79538&h=libreoffice-4-0-1

fdo#54087 build npsoplugin on Windows, it does not depend on GTK+ there


It will be available already in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Frank Fuchs 2013-03-28 15:47:53 UTC
I reopened this bug:
The LibreOffice Mozilla plugin is now copied to the appropriate LibreOffice program subdirectory - so this part works (again).
However, when you enable the option in the LO menu (extras-options-browser plug-in: show documents in browser), it still does not work, i.e. Firefox does not show the LO plugin as a loaded plugin. Going to the LO options dialog after that shows that the option to load documents in the browser is disabled (again).
Tested with LO 4.0.2.2 under Windows 7 32bit and W7 64 bit, both with FF 19.0.2.
Comment 19 Andras Timar 2013-04-30 11:27:49 UTC
It is wrong in 3.6.6, too. In Mozilla Firefox profile, in pluginreg.dat there is:

[INVALID]
C:\Program Files\LibreOffice 3.6\program\npsoplugin.dll|$
1367319401305|$

It might be a gbuildification problem.
Comment 20 Commit Notification 2013-05-02 17:13:12 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ae3f7b70a84f330f76e2e60c4c6bc8c69dbf068f

fdo#54087 link the correct resource file to npsoplugin.dll



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2013-05-03 05:09:59 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=940ecd8ab84429b4973a20e6990ed338d7d7a81e&h=libreoffice-4-0

fdo#54087 link the correct resource file to npsoplugin.dll


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2013-05-03 05:18:17 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8ec5216464e99feb5b6debfb517cc7b19a74739&h=libreoffice-3-6

fdo#54087 link the correct resource file to npsoplugin.dll


It will be available in LibreOffice 3.6.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Andras Timar 2013-05-03 06:42:38 UTC
The second problem that is mentioned in Comment 5, is fixed now. The plugin is built, installed, Firefox can load it, and Firefox can open LibreOffice file types. 

The first problem, i.e. the checkbox state is not preserved in Tools - Options - Internet - Browser Plug-in, is a different issue. LibreOffice tries to write to HKEY_LOCAL_MACHINE\SOFTWARE\MozillaPlugins, and it fails silently without appropriate privileges. It used to work on Win 9x/Win 2000/XP, where the user usually had administrator privileges. I think we should rather use HKEY_CURRENT_USER\Software\MozillaPlugins key.
Comment 24 Commit Notification 2013-05-04 17:01:19 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e61ea2d79f96a96314f0135ad6cf820b6ae57b5d

fdo#54087 refactor/fix browser plugin detection on Windows



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2013-05-06 12:19:12 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c0126be4cca4a88aa7b5d2a36962e9828c9b2c15&h=libreoffice-3-6

fdo#54087 refactor/fix browser plugin detection on Windows


It will be available in LibreOffice 3.6.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Commit Notification 2013-05-06 12:19:32 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f577975db513c2108600a1fabd1f7560c95b3db2&h=libreoffice-4-0

fdo#54087 refactor/fix browser plugin detection on Windows


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.