Download it now!
Bug 54181 - full installation with all modules causes windows explorer to fail and restart repeatedly
Summary: full installation with all modules causes windows explorer to fail and restar...
Status: RESOLVED DUPLICATE of bug 52078
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-29 03:19 UTC by Lorali Totten
Modified: 2012-09-17 16:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lorali Totten 2012-08-29 03:19:08 UTC
laptop running window 7 pro, installed every modules except some of the dictionaries, as soon as i tried to open Libre office, windows explorer crashed and restarted repeatedly.  I had to control alt delete to restart.  After several attempts to restart with immediately window explorer crashing and restarting, i had to restart in safe mode and conduct a repair on the.  It then booted successfully.  I noticed that Libre office 3.6 was no longer installed.

I reinstalled it the same way only to have the same issues.  

Once the computer successfully rebooted, i reinstalled Libre office but without the explorer interface and a couple of the other optional modules that looked suspect.  No more issues even when running libre office.
Comment 1 bfoman (inactive) 2012-08-29 09:24:28 UTC
(In reply to comment #0)
> Once the computer successfully rebooted, i reinstalled Libre office but without
> the explorer interface and a couple of the other optional modules that looked
> suspect.  No more issues even when running libre office.

Could you enlist them all?
Comment 2 bfoman (inactive) 2012-08-30 18:38:27 UTC
Please comment in the bug, not by replying to the mail received: https://bugs.freedesktop.org/show_bug.cgi?id=54181
Comment 3 Lorali Totten 2012-08-30 19:11:04 UTC
Mobile device filters, active X control, windows explorer extension, quickstarter.  The other modules were all set at the default except that I made sure that all portions of the actual program modules were turned on to install.  I believe it was the windows explorer extension that was the issue. The first time I tried to install, a message opened that said the program needed to modify files being used by windows explorer and could not unless that program was closed.
Comment 4 Winfried Donkers 2012-08-31 09:32:03 UTC
I kind of confirm this bug:
Windows XP pro, LibO version 3.6.1.2 (full installation):
When in explorer and moving mouse over .odb files, Explorer crashes.
Disabling shell extension 'LibreOffice Infotip Handler' (version 3.6.1.2, shlxthdl.dll) solves the problem: no more crashes.

This bug is probably related to bug 53534 and/or bug 52078.
Comment 5 jkwold 2012-09-09 03:34:25 UTC
Also on WinXP 32-bit, this time Media Center edition, with LibO 3.6.1.2 installed, steps:

-  Start -> Run -> Explorer [enter]
-  window appears, on mouseover faults


0:015> kb
ChildEBP RetAddr  Args to Child              
WARNING: Stack unwind information not available. Following frames may be wrong.
040de640 5ee72c5d 2005aef7 00000000 5eea540c shlxthdl!DllCanUnloadNow+0x76f7
040de728 5ee72d70 040de758 2005aeb7 00000000 shlxthdl!DllCanUnloadNow+0x8f4d
040de768 5ee6aef5 5eea540c 2005a50f 02e5b390 shlxthdl!DllCanUnloadNow+0x9060
040decd0 7ca3ecd5 03a55a14 02e5b5bc 00000000 shlxthdl!DllCanUnloadNow+0x11e5
040decf0 7ca5720f 02e5b390 00000000 02e06a48 SHELL32!CExtractImageTask::Run+0x5e
040ded18 7ca575b5 02e5b390 00000000 040df7a4 SHELL32!CTestCacheTask::RunInitRT+0x282
040def94 7ca492ad 040df12c 00000087 02e2a8d0 SHELL32!CDefView::ExtractItem+0x341
040df150 7c9f3363 02e2a8d0 040df7a4 02e06a48 SHELL32!CDefView::_GetDisplayInfo+0x20f
040df3c8 7c9f3093 040df7a4 02e06a48 02e06a48 SHELL32!CDefView::_OnLVNotify+0x260
040df3e0 7c9f2f04 040df7a4 00000000 02e06a48 SHELL32!CDefView::_OnNotify+0x7c
040df554 7c9f2f78 004c0314 0000004e 00000001 SHELL32!CDefView::WndProc+0x860
040df598 7e418734 004c0314 0000004e 00000001 SHELL32!CDefView::s_WndProc+0x72
040df5c4 7e418816 7c9f2f22 004c0314 0000004e USER32!InternalCallWinProc+0x28
040df62c 7e42927b 000a0270 7c9f2f22 004c0314 USER32!UserCallWinProcCheckWow+0x150
040df668 7e4292e3 005cca00 0059f4d8 00000001 USER32!SendMessageWorker+0x4a5
040df688 773eb00c 004c0314 0000004e 00000001 USER32!SendMessageW+0x7f
040df720 77416ec0 02dc9168 ffffff4f 040df7a4 comctl32!CCSendNotify+0xc20
040df7e4 77421985 02dc9168 00000002 040df9b0 comctl32!ListView_OnGetItem+0x364
040df948 7e418734 00a40342 0000104b 00000000 comctl32!ListView_WndProc+0xce8
040df974 7e418816 77420c9d 00a40342 0000104b USER32!InternalCallWinProc+0x28
040df9dc 7e42a013 000a0270 77420c9d 00a40342 USER32!UserCallWinProcCheckWow+0x150
040dfa0c 7e42a039 77420c9d 00a40342 0000104b USER32!CallWindowProcAorW+0x98
040dfa2c 6c1e6093 77420c9d 00a40342 0000104b USER32!CallWindowProcW+0x1b
040dfa5c 7e418734 00000000 0000104b 00000000 DUSER!WndBridge::RawWndProc+0xa2
040dfa88 7e418816 04b70fe0 00a40342 0000104b USER32!InternalCallWinProc+0x28
040dfaf0 7e428ea0 000a0270 04b70fe0 00a40342 USER32!UserCallWinProcCheckWow+0x150
040dfb44 7e428eec 005ccab0 0000104b 00000000 USER32!DispatchClientMessage+0xa3
040dfb6c 7c90e473 040dfb7c 00000018 005ccab0 USER32!__fnDWORD+0x24
040dfb90 7e41ec3e 6c1e4de0 040dfc10 00000000 ntdll!KiUserCallbackDispatcher+0x13
040dfbd0 6c1e4e8e 040dfc10 00000000 00000000 USER32!NtUserRealInternalGetMessage+0xc
040dfbf0 7e41ec76 040dfc10 00000000 00000000 DUSER!MphProcessMessage+0x2e
040dfc38 7c90e473 040dfc48 00000014 00000000 USER32!__ClientGetMessageMPH+0x30
040dfc58 7e4193e9 7e4193a8 040dfcd8 00000000 ntdll!KiUserCallbackDispatcher+0x13
040dfc84 7e419402 040dfcd8 00000000 00000000 USER32!NtUserPeekMessage+0xc
040dfcb0 75fa5109 040dfcd8 00000000 00000000 USER32!PeekMessageW+0xbc
040dff20 75fa5389 000f7878 00000000 00000000 BROWSEUI!BrowserThreadProc+0x227
040dffb4 7c80b729 000f7878 00000000 00000000 BROWSEUI!BrowserProtectedThreadProc+0x50
040dffec 00000000 75fa5339 000f7878 00000000 kernel32!BaseThreadStart+0x37

I had never before heard of the various flat extensions; don't have any such.  Don't have .pdb files so the assembly is unadorned:

5ee713f7 6a04            push    4
5ee713f9 b850c1e85e      mov     eax,offset shlxthdl!DllCanUnloadNow+0x22440 (5ee8c150)
5ee713fe e877600100      call    shlxthdl!DllCanUnloadNow+0x1d76a (5ee8747a)
5ee71403 8bf9            mov     edi,ecx
5ee71405 8bf2            mov     esi,edx
5ee71407 8b06            mov     eax,dword ptr [esi]  ds:0023:00000000=????????

So the null in edi comes from edx, which I'd have expected to be set by the function at 5ee8747a if its return value is 64-bit -- but I don't see that function setting edx, so I expect it has a 32-bit return value:

5ee8747a 50              push    eax
5ee8747b 64ff3500000000  push    dword ptr fs:[0]
5ee87482 8d44240c        lea     eax,[esp+0Ch]
5ee87486 2b64240c        sub     esp,dword ptr [esp+0Ch]
5ee8748a 53              push    ebx
5ee8748b 56              push    esi
5ee8748c 57              push    edi
5ee8748d 8928            mov     dword ptr [eax],ebp
5ee8748f 8be8            mov     ebp,eax
5ee87491 a1304bea5e      mov     eax,dword ptr [shlxthdl!DllCanUnloadNow+0x3ae20 (5eea4b30)]
5ee87496 33c5            xor     eax,ebp
5ee87498 50              push    eax
5ee87499 8965f0          mov     dword ptr [ebp-10h],esp
5ee8749c ff75fc          push    dword ptr [ebp-4]
5ee8749f c745fcffffffff  mov     dword ptr [ebp-4],0FFFFFFFFh
5ee874a6 8d45f4          lea     eax,[ebp-0Ch]
5ee874a9 64a300000000    mov     dword ptr fs:[00000000h],eax
5ee874af c3              ret

Not sure I've analyzed that properly, hope it helps.
Comment 6 jkwold 2012-09-09 03:37:08 UTC
Oops.  I said "null in edi", meant "null in esi".
Comment 7 jkwold 2012-09-09 03:52:05 UTC
Succeeded with the workaround as https://bugs.freedesktop.org/show_bug.cgi?id=52078

-  cd "C:\Program Files\LibreOffice 3.6\program\shlxthdl"
-  regsvr32 /u shlxthdl.dll
Comment 8 Andras Timar 2012-09-17 16:03:03 UTC
I think fix of bug 52078 and its family has fixed this one, too. Please reopen, when you see it in 3.6.2.

*** This bug has been marked as a duplicate of bug 52078 ***