Download it now!
Bug 54214 - FILESAVE: # in hyperlink corrupts .docx (OOXML) document
Summary: FILESAVE: # in hyperlink corrupts .docx (OOXML) document
Status: RESOLVED DUPLICATE of bug 47669
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-08-29 14:31 UTC by Rainer Bielefeld Retired
Modified: 2012-10-13 06:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-29 14:31:03 UTC
This one is a spin off from "Bug 51034 - FILESAVE: # in hyperlink corrupts .docx (MSO2007) document", Commenter Timur found an additional aspect of the problem what is not healed by the fix for that bug.

[Reproducible] with "LibreOffice 3.6.1.2  German UI/Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit) for Attachment 66225 [details] of a.m. Bug.

Still [Reproducible] with unzipped Master Build  "LOdev " 3.7.0.0.alpha0+  ENGLISH UI  [Build ID: 9ca3b53]" (tinderbox:W2008R2@20, pull time 2012-08-28 21:50:05) // WIN7 Home Premium (64bit) for Attachment 66225 [details] of a.m. Bug.

NEW due to results in a.m. Bug.
Currently only reproduced with WIN, but I am pretty sure that all OS are affected.

Steps how to reproduce:
1. Download / open Attachment 66225 [details] from LibO Start Center File Dialog
2. Save without edits under new name as .docx (does not matter whether as
   OOXML or MSO2007)
3. Close and reopen: All contents behind first link is missing
4. Close
5. Try to open with MS WORD viewer
   > Impossible, Error message 

The documents created by LibO have less than half size from original.

I did not test whether the problem really is "#" related.

@Miklos:
Please feel free to mar this one as DUP of Bug 51034 if you think that that proceeding would be more efficient.
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 1 Rainer Bielefeld Retired 2012-08-29 14:44:07 UTC
Worked a little better with Server Installation of "LibreOffice 3.5.1.2 German UI/Locale [Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66] on German WIN7 Home Premium (64bit), here only text behind last hyperlink is lost and already not usable for MS WORD VIEWER.

Worked fine with 3.4.5, so Regression
Comment 2 Korrawit Pruegsanusak 2012-10-13 06:39:01 UTC

*** This bug has been marked as a duplicate of bug 47669 ***