Bug Hunting Session
Bug 54225 - MAILMERGEe-mail as PDF sends damaged documents
Summary: MAILMERGEe-mail as PDF sends damaged documents
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:3.7.0
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2012-08-29 19:18 UTC by Rainer Bielefeld Retired
Modified: 2014-08-21 09:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
testkit (39.69 KB, application/x-7z-compressed)
2012-08-29 20:43 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-08-29 19:18:09 UTC
I observe with  unzipped Master Build  "LOdev " 3.7.0.0.alpha0+  ENGLISH UI  [Build ID: 9ca3b53]" (tinderbox:W2008R2@20, pull time 2012-08-28 21:50:05) // WIN7 Home Premium (64bit) that document sent via mailmerge wizard is damaged. More info following soon, I still have to do some research, it's not easy to create a sample document from my original document.
Comment 1 Rainer Bielefeld Retired 2012-08-29 20:43:49 UTC
Created attachment 66293 [details]
testkit

You should be able to reproduce the problem by simply sending the loremipsum test document using mailmerge wizard by e-mail to yourself. PDF document can't be opened with AR X, error message.

Result of export to PDF is without problems, AR X can open those documents.
Comment 2 Stephan Bergmann 2012-09-28 10:46:11 UTC
Have no software available to open the attached 7z-compressed testkit; please use standard archive formats (.zip or .tar.gz).

If this were about hybrid PDF format, where the enclosed ODF data is corrupted, it would likely be a duplicate of bug 54744, but that would not explain "PDF document can't be opened with AR X, error message."
Comment 3 Stephan Bergmann 2012-09-28 11:07:10 UTC
> You should be able to reproduce the problem by simply sending the loremipsum
> test document using mailmerge wizard by e-mail to yourself. PDF document
> can't be opened with AR X, error message.

Also not sure what exactly you mean there.  In Writer, "File - Send - E-mail as PDF..."?
Comment 4 Rainer Bielefeld Retired 2012-09-29 18:15:30 UTC
> Also not sure what exactly you mean there.  In Writer, "File - Send - E-mail as
> PDF..."?

No, we are talking about
<http://help.libreoffice.org/Writer/Mail_Merge_Wizard>

Still  [Reproducible] with parallel installation of Master "LOdev 
3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: bc63efc]" 
{tinderbox: @6, pull time 2012-09-24 21:00:28} on German WIN7 Home 
Premium (64bit)
Comment 5 Not Assigned 2012-10-01 13:45:14 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=968ed85d7304fe0044d3f82af20ae7190ad3c33d

fdo#54225: PDFExport::mbSignPDF potentially used uninitialized



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Chris Wilson 2014-08-21 09:28:36 UTC
*** Bug 82901 has been marked as a duplicate of this bug. ***