Bug Hunting Session
Bug 54232 - UI: Installer displays question marks instead of Romanian characters ș and ț
Summary: UI: Installer displays question marks instead of Romanian characters ș and ț
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.6.1.1 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0 target:3.5.7 target:3.6.3
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-29 21:13 UTC by Cristian Adam
Modified: 2013-11-16 13:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Question makrs in UI (37.69 KB, image/png)
2012-08-29 21:13 UTC, Cristian Adam
Details
Libre Office 3.6.3 still has some question marks (42.30 KB, image/png)
2012-11-04 00:02 UTC, Cristian Adam
Details
Libre Office 3.6.3 still has some question marks (42.30 KB, image/png)
2012-11-04 00:05 UTC, Cristian Adam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cristian Adam 2012-08-29 21:13:02 UTC
Created attachment 66300 [details]
Question makrs in UI

I've installed LibO_3.6.1_Win_x86_install_multi.msi on my Windows 7 64bit with Romanian locale setup as default.

The UI of the installer was switched to Romanian translation which had ș and ț characters (s and t comma below) presented as question marks (?).

This is due the fact that MSI technology is not Unicode aware, as presented here:
http://blogs.msdn.com/b/michkap/archive/2005/10/08/478479.aspx

It seems there is a work around, to use the codepage 65001 (utf-8) for the installer scripts, as presented on the WiX forums:
http://www.mail-archive.com/wix-users@lists.sourceforge.net/msg14191.html
Comment 1 Rainer Bielefeld Retired 2012-08-30 05:22:03 UTC
Font problem?
Comment 2 Cristian Adam 2012-08-30 05:54:29 UTC
Not a font problem. 

S and T comma below (ș U+0219, Ș U+0218 and ț U+021B, Ț U+021A) can be rendered by Microsoft Sans Serif and Tahoma font families since at least Windows 2000.

The problem is that these characters are not mapped by Microsoft in any code page, and they have to be in a code page in order to be used in a Windows Installer.

The characters are mapped by ReactOS in code page 28606, but this doesn't help any Windows user :)

You can use the old and incorrect S and T cedilla (ş U+015F, Ş U+015E and ţ U+0163, Ţ U+0162) as substitutes since they are part of Windows code page 1250.

This shows that LibreOffice installer cannot display Unicode characters which are outside Windows code pages, and I'm sure there are other languages than Romanian which are affected.
Comment 3 Cristian Adam 2012-08-30 06:55:36 UTC
Actually the MSI file contains the strings directly with question marks.

I had a peek inside of the file using Total Commander:

"Eroare la ob?inerea securită?ii fi?ierului: [3] GetLastError: [2]Unitate invalidă: [2]Sigur dori?i să renun?a?i?Nu mai este spa?iu liber pe disc -- Volum: [2]; spa?iu necesar: [3] KO; spa?iu disponibil: [4] KO. Dacă este dezactivată op?iunea de anulare a pa?ilor anteriori, atunci există spa?iu suficient. Apăsa?i „Renun?ă” pentru a ie?i, „Încearcă din nou” pentru a verifica din nou spa?iul pe disc sau „Ignoră” pentru a continua fără posibilitatea de a anula pa?ii făcu?i anterior.Nu se poate accesa loca?ia [2] din re?ea.Pentru a continua instalarea, următoarele aplica?ii trebuiesc închise:Cheia [2] nu este validă. Verifica?i dacă a?i introdus corect cheia.Nu a putut fi găsită nici o sursă valabilă pentru produsul [2]."

It doesn't matter if the system has a code page containing the correct Romanian characters, the string already comes with question marks.
Comment 4 Andras Timar 2012-09-17 19:57:34 UTC
I set encoding of Romanian MSI tables to UTF-8. I did not find any obvious problems after that, I saw the special characters on UI.

But... I remember when I wanted to get rid of legacy encodings in MSI and I set all languages to UTF-8, I saw strange word breaking problems. Lines were broken in the middle of words, not at word boundaries. I did not see this now in Romanian installer, but many strings are not translated there. Please check carefully and reopen this bug, when you see issues. 

Alternatively we could patch character conversion tables (sal/textenc/tcvtest1.tab) and fall back to ş and ţ in installer.
Comment 5 Not Assigned 2012-09-17 20:05:49 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=41086934cfb39f491c3f81e38a0286d66b2772cf

fdo#54232 set encoding of Romanian MSI tables to UTF-8



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Not Assigned 2012-09-18 07:14:12 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=324ddd22f703545cdcffecb18d7a5e763ae62756&g=libreoffice-3-5

fdo#54232 set encoding of Romanian MSI tables to UTF-8


It will be available in LibreOffice 3.5.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Not Assigned 2012-09-18 07:14:31 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e6158f4fa2890d2f7bb3cc12dc3ce8e20d8511c3&g=libreoffice-3-6

fdo#54232 set encoding of Romanian MSI tables to UTF-8


It will be available in LibreOffice 3.6.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Cristian Adam 2012-11-04 00:02:38 UTC
Created attachment 69505 [details]
Libre Office 3.6.3 still has some question marks
Comment 9 Cristian Adam 2012-11-04 00:03:36 UTC
Tested Libre Office 3.6.3, almost perfect, the progress label still has some question marks.
Comment 10 Cristian Adam 2012-11-04 00:05:10 UTC
Created attachment 69506 [details]
Libre Office 3.6.3 still has some question marks
Comment 11 Julien Nabet 2013-09-27 19:33:34 UTC
Cristian: just for the updated, is it better with LO 4.1.1?
Comment 12 Cristian Adam 2013-10-17 17:32:10 UTC
I've installed version 4.1.2.3 and haven't seen the question marks anymore
Comment 13 Julien Nabet 2013-10-17 18:00:36 UTC
Christian: thank you for your feedback, since there's no specific fix, I'll put WFM.