Download it now!
Bug 54249 - : explorer goes to 100% cpu when viewing folders that contain .odp files
Summary: : explorer goes to 100% cpu when viewing folders that contain .odp files
Status: RESOLVED DUPLICATE of bug 53588
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-30 07:56 UTC by Markus Hoenicka
Modified: 2012-09-07 19:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of task manager showing running processes and cpu usage (34.00 KB, image/png)
2012-08-30 07:56 UTC, Markus Hoenicka
Details
.odt file that freeses CPU and screenshot of CPU use (2.10 MB, application/x-zip-compressed)
2012-09-07 05:01 UTC, Timon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Hoenicka 2012-08-30 07:56:09 UTC
Created attachment 66317 [details]
screenshot of task manager showing running processes and cpu usage

Problem description: 
The cpu load goes to 100% if I open a folder in explorer that contains at least one .odp file.
  
Steps to reproduce:
1. Install LibreOffice 3.6.0 or 3.6.1
2. Open a folder in Windows explorer that contains some .odp file
3. watch the cpu load rise. If I right-click on the .odp file and select "Properties", the dialog box will show the first tab. Trying to switch to a different tag makes the dialog unresponsive. The only way out is to kill the entire explorer process.

Expected behavior:

Opening a folder containing .odp files must not make the cpu spin.

Currently the only fix is to deinstall 3.6.x and reinstall 3.5.6

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:15.0) Gecko/20100101 Firefox/15.0
Comment 1 Timon 2012-09-07 05:01:02 UTC
Created attachment 66759 [details]
.odt file that freeses CPU and screenshot of CPU use

LibreOffice 3.6.1.2 (Final) (Build ID e29a214) Russian UI/Locale on Russian
Windows XP Professional SP3 (32bit)

The same behaviour when try to open folder in Windows explorer with .odt files. The more files in folder, the more all freeses. The larger file is, the longer all works. When rightclick on any .odt file to get popup menu, it appears after 10 or more seconds with high CPU utilisation. During CPU load files are locked and can't be removed.
In Total Commander 8.01 such behavior is not observed. Folders are opened in a flash, menu popups on rightclick without problems.

The same problem rises here http://ask.libreoffice.org/question/5713/another-nasty-feature-unable-to-open-odf-file-from/
Comment 2 manj_k 2012-09-07 19:37:47 UTC
Thanks, already reported as 'Bug 53588 - Open document file preview will block windows explorer for several seconds everytime a document is selected' (also marked as LO 3.6 MAB).

*** This bug has been marked as a duplicate of bug 53588 ***