Bug Hunting Session
Bug 54276 - Do not merge mergemodules into all language msi
Summary: Do not merge mergemodules into all language msi
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:3.7.0 target:3.6.3
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-30 17:04 UTC by Andras Timar
Modified: 2012-09-24 14:49 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2012-08-30 17:04:27 UTC
In solenv/bin/modules/installer.pm find the line:
# if there are Merge Modules, they have to be integrated now

The problem is that it is a terrible idea to integrate MS VC++ runtime merge modules into all language msi files (109 in case of a release build), then drop those msi files later, when the transforms are made. Instead, let's generate language transforms first, and integrate merge modules later, into the final multi language msi file. It could save 2-3 hours on an average build machine, when all languages are built.
Comment 1 Not Assigned 2012-09-23 20:11:22 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=44e46183cf0771ef872b89a164651109a2abb012

fdo#54276 speed up packaging on Windows significantly



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Not Assigned 2012-09-24 14:49:22 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4de0fe45570ec04303d955e153592d45851c7b4b&g=libreoffice-3-6

fdo#54276 speed up packaging on Windows significantly


It will be available in LibreOffice 3.6.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.