Download it now!
Bug 54303 - FILEOPEN: specific XLS (Office 2003) file crashes LibO 3.6
Summary: FILEOPEN: specific XLS (Office 2003) file crashes LibO 3.6
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: All All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.7.0 target:3.6.2
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-31 07:11 UTC by Karel Behounek
Modified: 2012-09-09 19:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample file that causes LibO 3.6 crashing (267.00 KB, application/vnd.ms-excel)
2012-08-31 07:11 UTC, Karel Behounek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karel Behounek 2012-08-31 07:11:07 UTC
Created attachment 66384 [details]
sample file that causes LibO 3.6 crashing

Problem description: 

There are specific files created in MS Office 2003 which cause LibO 3.6.0 /
3.6.1 crashing (when opened). The same files worked fine with LibO 3.4.x/3.5.x. Sample file attached.

Steps to reproduce:
1. (try to) open the attached file

Current behavior: LibreOffice crashes with the message "Due to an unexpected
error, LibreOffice crashed. All the files you were working on will now be
saved. The next time LibreOffice is launched, your files will be recovered
automatically."

Expected behavior: the file opens
Comment 1 Kohei Yoshida 2012-08-31 16:50:14 UTC
Taking it.
Comment 2 Not Assigned 2012-08-31 16:52:55 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b4f913b5f5c48335dc80a5322b078e1d6ac2e3fe

fdo#54303: Prevent crash on load.
Comment 3 Not Assigned 2012-08-31 17:15:50 UTC
Kohei Yoshida committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98ec92335d18bb361a63cea3e1e71a87dddded2b&g=libreoffice-3-6

fdo#54303: Prevent crash on load.


It will be available in LibreOffice 3.6.2.
Comment 4 Jean-Baptiste Faure 2012-09-09 19:59:50 UTC
Verified in LO 3.6.2.0+ (Build ID: bb1511c) under Ubuntu 12.04 x86_64. No crash.
Bugdoc causes LibO 3.6.1 crashing under Linux too.

Best regards. JBF