Bug 54339 - BASIC: any use of "static" variables cause internal error!
Summary: BASIC: any use of "static" variables cause internal error!
Status: RESOLVED DUPLICATE of bug 54000
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
(earliest affected) release
Hardware: Other All
: medium normal
Assignee: Not Assigned
Whiteboard: BSA
Depends on:
Reported: 2012-08-31 19:53 UTC by Marc Sabatella
Modified: 2012-12-22 03:53 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Marc Sabatella 2012-08-31 19:53:26 UTC
Problem description: 

I have a very simple that references a static variable, has worked for over a year in all previous versions. Now, attempting to access the static variable generate "Internal error $(ARG1)"

Steps to reproduce:

Here's a trivial reduction of the bug.  Run the following:

Sub bug
	static myVar as Integer
	if myVar = 0 then
		msgbox("first time")
		myVar = 1
	end if
End Sub

Current behavior:

Internal error $(ARG1) upon the test "if myVar = 0"
Same result if you try to assign to myVar instead of query it - any attempt to reference a static variable fails

Expected behavior:

myVar is found equal to 0 first time the sub is run.

Platform (if different from the browser): 
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2
Comment 1 Martin Schniewind 2012-09-04 13:00:26 UTC
Confirmed for 3.5.6rc2 and

Very annoying - I hd to roll back to 3.4.6 again.
Comment 2 Marc Sabatella 2012-09-07 01:50:46 UTC
Is there something I have to do to get this moved off "UNCONFIRMED" status and toward a fix?  Seems this is likely to break a *lot* of extensions, and should be fixed sooner rather than later.
Comment 3 Dave Levitt 2012-09-14 13:45:02 UTC
Disappointing to see this is still both still present and 'unconfirmed'. See Bug 54000 for a code snippit illustrating the bug.
Comment 4 pierre-yves samyn 2012-09-15 07:36:46 UTC

Sorry I do not reproduce with Version (Build ID: ba822cc) (Windows 7 64bit and XP)

I do not reproduce bug 54000

Comment 5 Marc Sabatella 2012-09-15 17:13:17 UTC
Sorry if this shows up twice - I thought I submitted a comment but don't see it.

I can confirm this appears to have been fixed in 3.6.2 RC1.  At least, I can no longer duplicate.
Comment 6 LeMoyne Castle 2012-12-22 03:53:22 UTC

*** This bug has been marked as a duplicate of bug 54000 ***