Bug 54407 - VIEWING: Mac: busy wheel not native, it's time glass
Summary: VIEWING: Mac: busy wheel not native, it's time glass
Status: RESOLVED DUPLICATE of bug 52263
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 00:51 UTC by fenglich
Modified: 2015-01-08 10:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fenglich 2012-09-03 00:51:08 UTC
Problem description: 

On Mac OS X, the busy wheel isn't the native, but a monochrome time glass. It would be better if the busy wheel was native.

I presume this applies to the open office framework as a whole. Perhaps it's specific to Java and can't be changed? I don't know.

Steps to reproduce:
1. .... Trigger the busy wheel (block the event loop), such as by saving a file.


Current behavior:

Monochrome time glass.

Expected behavior:

Mac OS X's multi coloured, animated spinning wheel.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_1) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1
Comment 1 Roman Eisele 2012-11-14 19:07:17 UTC
Thank you for your bug report!

I am sorry that you did not get an answer earlier.

A question: Is this the same issue as in bug 52263 -- “Replace custom ‘hourglass’ pointer/cursor by the operating system's default wait pointer everywhere”? See
  https://bugs.freedesktop.org/show_bug.cgi?id=52263
I would think so ... What do you mean?

Another question, related: according to bug 52263, the old-style ‘hourglass’ pointer appears only sometimes, not always; in most situation, I see the “multi coloured, animated spinning wheel”. Is this the same for you? Or do you often/always see the old-style ‘hourglass’ pointer?

And could you please tell us which Mac OS X version you use, and if you use an old PPC or a new Intel-based Mac? This may be important to understand the problem ...

Thank you very much!
Comment 2 Emir Sarı 2012-11-23 02:41:47 UTC
I see this wheel when saving documents in Writer.

*** This bug has been marked as a duplicate of bug 52263 ***
Comment 3 Sierk Bornemann 2015-01-08 10:25:43 UTC
In reply to https://bugs.freedesktop.org/show_bug.cgi?id=53148#c4 :

The issue still exists also in LibreOffice Version: 4.4.0.1 and lower for Mac (OS X Yosemite 10.10.1).

Occurrence: start LibreOffice -> remain in main area of start center -> click on any shown recent document to open it


Please fix.