Bug Hunting Session
Bug 54453 - EDITING: Impossible to draw shapes in top margin or bottom margin
Summary: EDITING: Impossible to draw shapes in top margin or bottom margin
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-03 17:42 UTC by Ivan Timofeev (retired)
Modified: 2013-12-15 16:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot with comments (103.91 KB, application/x-download)
2012-09-03 18:05 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Timofeev (retired) 2012-09-03 17:42:38 UTC
1. Open a new writer doc.
2. Choose a shape from the drawing toolbar.
   => mouse pointer is "cross" now
3. Start drawing in the header or footer area.

Expected: a shape appears, now you should release the mouse button to end drawing.
Current: the Header/Footer indicator appears, drawing did not start.

OS: Linux, Windows

Can't provide a patch, sorry.
Comment 1 Rainer Bielefeld Retired 2012-09-03 18:05:41 UTC
Created attachment 66566 [details]
Screenshot with comments

Indeed, until "LibreOffice 3.6.1.2  German UI/ German Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit) it was possible to created drawints also out of the contents area on the margins.

Now with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 9bb30a4]"  {tinderbox: 2008R2@20, pull time 2012-08-30 23:44:35} on German WIN7 Home Premium (64bit) that's still possible in the green area (left / right margin), but no longer in the red areas (top / bottom margin)

But in header and footer (when created) it's still possible to draw shapes. 

Bug or feature, that's the question here. To me the old way seemed more flexible.
Comment 2 Rainer Bielefeld Retired 2012-09-03 18:08:07 UTC
@Cedric:
Is that new behavior intended or accidently with fix for "Bug 46141 - UI: Header/footer prompts should only appear if user clicks in header/footer area"?
Comment 3 Joel Madero 2012-12-06 17:26:04 UTC
I'm going to go ahead and mark this as NEW and once it's decided bug/feature we can edit that. Just trying to get through the UNCONFIRMED Version 4 list
Comment 4 Rainer Bielefeld Retired 2013-01-27 08:45:22 UTC
Problem with access to elements in top and bottom margin area already reproducible with WIN version
* 3.6.2

Still was ok with WIN version
* 3.6.0.4

This seems to be a special case of the more general "Bug 55842 - EDITING: no access to objects in of top margin or bottom margin area"
Comment 5 Ivan Timofeev (retired) 2013-12-15 16:57:34 UTC
apparently it is fixed.