Download it now!
Bug 54464 - Conditional formatting is lost when the file is saved
Summary: Conditional formatting is lost when the file is saved
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 54508 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-03 20:59 UTC by keyopen
Modified: 2014-09-19 01:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Original Excel spreadsheet wtih conditional formatting in A6 (13.50 KB, application/vnd.ms-excel)
2012-09-11 20:32 UTC, Lawrence R. Steeger
Details
3.6.1.2 ods document created by saving as ods (11.27 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-09-11 20:33 UTC, Lawrence R. Steeger
Details
3.3.1.2 ods document created by saving as ods (11.60 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-09-13 19:30 UTC, Lawrence R. Steeger
Details
Cell with conditional formating (7.64 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-09 17:10 UTC, Andreas Blochberger
Details
File after autofill (7.76 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-11-09 17:10 UTC, Andreas Blochberger
Details
Excel Spreadsheet which demonstrate conditional format bug (38.00 KB, application/vnd.ms-excel)
2014-09-17 07:03 UTC, Wolfgang Alge
Details

Note You need to log in before you can comment on or make changes to this bug.
Description keyopen 2012-09-03 20:59:14 UTC
I have an old file where there is some cells with contitional formatting. When Isaved it, at the reopen I didn't see that formatting. I made conditional formatting again,but at the reopen of file, after a save, the formatting was losta again.
In the reopened file, the list of formatting, in" Manage" menu, it's empty.
Comment 1 Markus Mohrhard 2012-09-04 00:13:46 UTC
Can you please attach a test document?
Comment 2 Lawrence R. Steeger 2012-09-11 20:32:37 UTC
Created attachment 66997 [details]
Original Excel spreadsheet wtih conditional formatting in A6
Comment 3 Lawrence R. Steeger 2012-09-11 20:33:40 UTC
Created attachment 66998 [details]
3.6.1.2 ods document created by saving as ods

Cell A6 is losing its formatting.
Comment 4 Lawrence R. Steeger 2012-09-13 19:30:21 UTC
Created attachment 67116 [details]
3.3.1.2 ods document created by saving as ods

Attachment 66997 [details]: Original Excel spreadsheet wtih conditional formatting in A6

An original Excel spreadsheet with conditional formatting on cell A6


Attachemnt 66998: 3.6.1.2 ods document created by saving as ods

The output of 3.6.1.2 created by saving as ods. Conditional formatting is gone!


Attachemnt: 3.3.1.2 ods document created by saving as ods

The output of 3.3.1.2 created by saving as ods. Conditional formatting is Ok!
Comment 5 Roman Eisele 2012-09-16 13:38:41 UTC
@Lawrence R. Steeger:
Thank you very much for the good test files!


Tested with the reporter’s test files on Mac OS X 10.6.8 (Intel).

1) With LibreOffice 3.5.6.2, BOTH .ods files (both the one created with LibO 3.3.1.2 and the one created with 3.6.1.2) open correctly, i.e., the cell A6 is displayed in red, and the “Conditional formatting” dialog window (accessible from the menu via “Format > Conditional Formatting > Conditional Formatting...“) correctly lists the rule to make the cell contents red if the value of the cell is = 5.

2) With LibreOffice 3.6.1.2 (Build ID: e29a214), as the user said, only the .ods file created with LibO 3.3.1.2 opens correctly, but the .ods file created wth LibO 3.6.1.2 misses all conditional formatting for cell A6: the cell text is black, and the “Conditional formatting” dialog window (accessible from the menu via “Format > Conditional Formatting > Conditional Formatting...“) does not list any formatting rules.

So this is (at least partially) a FILEOPEN problem introduced in LibreOffice 3.6.0 or 3.6.1, therefore I add the keyword “regression”.

3) But, good news: LibreOffice 3.6.2.1 (Build ID: ba822cc; the 1st pre-release of the new 3.6.2 version) opens again both files .ods files correctly, i.e. with the conditional formatting of cell A6, just like LibreOffice 3.5.6.2.


So the regression is IMHO already fixed in LibreOffice 3.6.2.1, therefore I set the status of this bug report to RESOLVED/WORKSFORME.


@keyopen,
@Lawrence R. Steeger:
You can test yourself whether LibreOffice 3.6.2.1 solves the problem or not if you download that version from

   http://www.libreoffice.org/download/pre-releases/

Feel free to reopen this bug report if you can still reproduce the problem with LibreOffice 3.6.2.1. Thank you!
Comment 6 Lawrence R. Steeger 2012-10-04 09:21:06 UTC
*** Bug 54508 has been marked as a duplicate of this bug. ***
Comment 7 Andreas Blochberger 2012-11-09 08:59:05 UTC
It is still reproducible with Version 3.6.2.2 (Build ID: 360m1(Build:2)) on Kubuntu 12.10

Saving the Excel file and reopen it loses the conditional formatting.
Comment 8 Andreas Blochberger 2012-11-09 17:10:12 UTC
Created attachment 69828 [details]
Cell with conditional formating

It is not related to Excel. When i create a conditional formatting in a cell, and then use autofill, the conditional formatting is copied to the cells. After saving and reloading, the conditional formatting in the other cells is gone
Comment 9 Andreas Blochberger 2012-11-09 17:10:46 UTC
Created attachment 69829 [details]
File after autofill
Comment 10 Markus Mohrhard 2012-11-10 03:19:54 UTC
(In reply to comment #9)
> Created attachment 69829 [details]
> File after autofill

Please open a new bug report for the autofill problem. The autofill should normall not copy conditional formats but I have to investigate why this happens. If this was the only problem that resulted in reopening this bug report please also close this bug report again. I will try to keep track of the problem than in the new bug report.
Comment 11 Roman Eisele 2012-11-10 09:53:45 UTC
... and please do not “update” the Version field ;-): it should always contain the *first* version in which a bug is known to exist, and not the last one.
Comment 12 Markus Mohrhard 2012-11-13 06:12:17 UTC
Marking as fixed. Please open the new bug report and put me in cc there.
Comment 13 Joel Madero 2013-04-27 16:01:01 UTC
As part of regular FDO maintenance we are checking minor release regression versions to ensure that it was introduced during a minor release.

I can confirm this exact behavior on 3.6.0.4 release 

Updating version
Comment 14 Wolfgang Alge 2014-09-17 07:03:39 UTC
Created attachment 106409 [details]
Excel Spreadsheet which demonstrate conditional format bug

After saving and re-open this file the conditional format is gone
Comment 15 Wolfgang Alge 2014-09-17 07:06:33 UTC
This bug still exists in Version V4.3.0.4
It works correct on OpenOffice V4.1.1
See attachment:  "Excel Spreadsheet which demonstrate conditional format bug"
Comment 16 Joel Madero 2014-09-19 01:55:13 UTC
Please open a new bug. Markus is one of our spreadsheet experts and he closed this particular issue as FIXED because the particular issue is fixed. If you're seeing it on a different spreadsheet, it's likely it's not related. Marking again as FIXED. Please create a new bug report and if needed you can reference this one.