Bug Hunting Session
Bug 54542 - EDITING - Create Table Wizard doesn't start
Summary: EDITING - Create Table Wizard doesn't start
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) All
: highest blocker
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:3.7.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-05 10:12 UTC by Alex Thurgood
Modified: 2012-09-10 19:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
proposed patch (1.10 KB, text/plain)
2012-09-06 20:54 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2012-09-05 10:12:04 UTC
Version 3.7.0.0.alpha0+ (Build ID: 4deb9d4)

1) File New > Database

2) Create default HSQLDB database. 

3) Select defaults of New Database.odb as file name

4) Open the file for editing. Click on Tables.

5) Select "Use Wizard to create Table"


What should happen : Table creation wizard should start
What actually happens : nothing


Alex
Comment 1 Alex Thurgood 2012-09-05 10:13:42 UTC
@Lionel, Julien : adding you guys to take a look ?

I tested this on Mac OSX, daily build from 30/08

Alex
Comment 2 Alex Thurgood 2012-09-05 10:15:40 UTC
Also confirmed with separate ODB file that I had already made in previous versions of LO. If I open the file, click on the Tables icon, then click on the Table Creation Wizard, nothing happens.

The Create View and the manual table creation entries work fine.


Alex
Comment 3 Julien Nabet 2012-09-05 10:19:22 UTC
@Alex: I launched a recompilation from scratch of master sources (future 3.7) this morning, so I'll be able to test tonight when come back home(so after my daytime work).
Comment 4 Julien Nabet 2012-09-06 06:32:14 UTC
On pc Debian x86-64 with master sources updated today, I reproduced the problem.
Here are the console logs:

com.sun.star.uno.RuntimeException: string resource for id not available
java stack trace:
	at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
	at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:166)
	at $Proxy18.getByIndex(Unknown Source)
	at com.sun.star.wizards.common.Resource.getResText(Resource.java:81)
	at com.sun.star.wizards.table.TableWizard.getTableResources(TableWizard.java:388)
	at com.sun.star.wizards.table.TableWizard.<init>(TableWizard.java:82)
	at com.sun.star.wizards.table.CallTableWizard$TableWizardImplementation.trigger(CallTableWizard.java:82)

	at com.sun.star.bridges.jni_uno.JNI_proxy.dispatch_call(Native Method)
	at com.sun.star.bridges.jni_uno.JNI_proxy.invoke(JNI_proxy.java:166)
	at $Proxy18.getByIndex(Unknown Source)
	at com.sun.star.wizards.common.Resource.getResText(Resource.java:81)
	at com.sun.star.wizards.table.TableWizard.getTableResources(TableWizard.java:388)
	at com.sun.star.wizards.table.TableWizard.<init>(TableWizard.java:82)
	at com.sun.star.wizards.table.CallTableWizard$TableWizardImplementation.trigger(CallTableWizard.java:82)
java.lang.IllegalArgumentException: Resource with ID not 2525not found
Comment 5 Roman Eisele 2012-09-06 13:24:01 UTC
(In reply to comment #4)
> On pc Debian x86-64 with master sources updated today, I reproduced the
> problem.

So this problem is not specific to Mac OS; therefore adapted Platform field.
Comment 6 Julien Nabet 2012-09-06 20:54:02 UTC
Created attachment 66747 [details]
proposed patch

I noticed in this commit:
5eb16c1cf277a8a3514e81e64b211a2e4f4c7a8f
(fixes to new template localization code)

this change in:wizards/source/formwizard/dbwizres.src
-#define RID_DB_TABLE_WIZARD_START 2500
+#define RID_DB_TABLE_WIZARD_START 2525

The problem is corresponding parts are in:
- wizards/com/sun/star/wizards/ui/UIConsts.py
- wizards/com/sun/star/wizards/ui/UIConsts.java
both contain this:
RID_TABLE = 2500

So I just propose to update the value to 2525 too here.
Comment 7 Julien Nabet 2012-09-06 20:56:26 UTC
Forgot to say, I tested the patch and it's ok.

@Andras and Lionel: what do you think about this proposed patch?

If ok with it, I can commit and push it on master.
Comment 8 Lionel Elie Mamane 2012-09-10 10:37:27 UTC
(In reply to comment #7)

> @Andras and Lionel: what do you think about this proposed patch?
 
> If ok with it, I can commit and push it on master.

Patch is OK. Commit.

What I wonder is why 5eb16c1cf277a8a3514e81e64b211a2e4f4c7a8f pushed the value of RID_DB_TABLE_WIZARD_START so "tight" to 2525 and not to 2600, to give RID_DB_REPORT space to grow in future...
Comment 9 Julien Nabet 2012-09-10 11:46:12 UTC
(In reply to comment #8)
> (In reply to comment #7)
> 
> > @Andras and Lionel: what do you think about this proposed patch?
> 
> > If ok with it, I can commit and push it on master.
> 
> Patch is OK. Commit.
Thank you for the feedback.
> 
> What I wonder is why 5eb16c1cf277a8a3514e81e64b211a2e4f4c7a8f pushed the value
> of RID_DB_TABLE_WIZARD_START so "tight" to 2525 and not to 2600, to give
> RID_DB_REPORT space to grow in future...

I'll be able to commit and push only tonight (after my day time work). So if you want to think more about the value  that RID_DB_TABLE_WIZARD_START should have (2600 or other) and post another comment here, don't hesitate to :-)

BTW, I know how to push/"submit-for-rewiew" with gerrit and here I thought about pushing directly but I don't know the gerrit process for asking cherry pick on other branches. (found nothing on these pages:
- http://wiki.documentfoundation.org/Development/gerrit
- http://wiki.documentfoundation.org/Development/gerrit/SubmitPatch
- wiki.documentfoundation.org/Development/GitReview
So by default I'll post on dev mailing list.
Comment 10 Lionel Elie Mamane 2012-09-10 12:46:53 UTC
(In reply to comment #9)
> (In reply to comment #8)

>> What I wonder is why 5eb16c1cf277a8a3514e81e64b211a2e4f4c7a8f pushed the value
>> of RID_DB_TABLE_WIZARD_START so "tight" to 2525 and not to 2600, to give
>> RID_DB_REPORT space to grow in future...

> I'll be able to commit and push only tonight (after my day time work). So if
> you want to think more about the value  that RID_DB_TABLE_WIZARD_START should
> have (2600 or other) and post another comment here, don't hesitate to :-)

Let's leave author & committer a chance to comment on that, maybe we are overlooking something.

> BTW, I know how to push/"submit-for-rewiew" with gerrit and here I thought
> about pushing directly but I don't know the gerrit process for asking cherry
> pick on other branches.

You do the cherry-pick yourself (recommended: in a detached HEAD state or a special-purpose branch just for *that* cherry-pick: e.g. branch "fdo54542"), and push the result to refs/for/BRANCH_NAME; ah no, that's "submit-for-review".

To push a cherry-pick directly, just do the cherry-pick and push it, as if there were no gerrit (but push to the gerrit.libreoffice.org repository, not to git.freedesktop.org).

But I don't understand why you ask here, as no other branch is affected, or did I miss that?

Just to be clear: I haven't OKed the patch for any release branch (libreoffice-3-5, libreoffice-3-6, etc). In my mind it was intended only for master, since only master is affected.
Comment 11 Julien Nabet 2012-09-10 12:52:14 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > (In reply to comment #8)
> 
> >> What I wonder is why 5eb16c1cf277a8a3514e81e64b211a2e4f4c7a8f pushed the value
> >> of RID_DB_TABLE_WIZARD_START so "tight" to 2525 and not to 2600, to give
> >> RID_DB_REPORT space to grow in future...
> 
> > I'll be able to commit and push only tonight (after my day time work). So if
> > you want to think more about the value  that RID_DB_TABLE_WIZARD_START should
> > have (2600 or other) and post another comment here, don't hesitate to :-)
> 
> Let's leave author & committer a chance to comment on that, maybe we are
> overlooking something.
OK

> But I don't understand why you ask here, as no other branch is affected, or did
> I miss that?
Oups, you're right! :-)
> 
> Just to be clear: I haven't OKed the patch for any release branch
> (libreoffice-3-5, libreoffice-3-6, etc). In my mind it was intended only for
> master, since only master is affected.
Of course, moreover with the previous comment.
Sorry for the confusion
Comment 12 Andras Timar 2012-09-10 19:32:07 UTC
Thanks for the fix, Julien. It was an oversight from our side.
Comment 13 Not Assigned 2012-09-10 19:36:24 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=304247bbfd5bb46fc72bb2ed39711f6fc60ffef4

fdo#54542 fix start of table wizard IDs



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.