Bug 54590 - Macros in "Standard/Module1.xba" erased after upgrade to 3.6 on MacOS X 10.7
Summary: Macros in "Standard/Module1.xba" erased after upgrade to 3.6 on MacOS X 10.7
Status: RESOLVED DUPLICATE of bug 52022
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-06 10:55 UTC by fabien.michel
Modified: 2012-09-06 12:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
LibO 3.5 : Macros list dialog box (134.10 KB, image/png)
2012-09-06 10:55 UTC, fabien.michel
Details
LibO 3.5 : Macros list dialog box (101.60 KB, image/png)
2012-09-06 10:55 UTC, fabien.michel
Details
LibO 3.6 : Macros list dialog box (101.60 KB, image/png)
2012-09-06 10:56 UTC, fabien.michel
Details
Module1.xba 3.5 (995 bytes, application/octet-stream)
2012-09-06 10:57 UTC, fabien.michel
Details
Module1.xba after upgrade to 3.6 (305 bytes, application/octet-stream)
2012-09-06 10:58 UTC, fabien.michel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fabien.michel 2012-09-06 10:55:06 UTC
Created attachment 66719 [details]
LibO 3.5 : Macros list dialog box

Context :
In 3.5 i've created a macro in "My Macro > Standard > Module1"
nammed "paste_unformated" 
The goal of this macro is to remove format of copied cells when Cmd+V id pressed in calc.
(In custom shortcut dialog box, i've set Cmd+v to call this macro when pressed. Work well in 3.5)

The screenshot "35_macros_list" represent macro dialog box of LibO 3.5 : you can see the macro is present.
The screenshot "36_macros_list" represent macro dialog box in LibO 3.6 using the same user config folder (~/Library/Application support/Libreoffice) : you can see the macro isn't present.

I've watched the evolution of the Module1.xba file in user config folder : 
~/Library/Application Support/LibreOffice/3/user/basic/Standard/Module1.xba

I've attached version after quitting 3.5 and version after quitting 3.6
You can see that the file has been erased
Comment 1 fabien.michel 2012-09-06 10:55:50 UTC
Created attachment 66720 [details]
LibO 3.5 : Macros list dialog box
Comment 2 fabien.michel 2012-09-06 10:56:26 UTC
Created attachment 66721 [details]
LibO 3.6 : Macros list dialog box
Comment 3 fabien.michel 2012-09-06 10:57:33 UTC
Created attachment 66722 [details]
Module1.xba 3.5
Comment 4 fabien.michel 2012-09-06 10:58:28 UTC
Created attachment 66723 [details]
Module1.xba after upgrade to 3.6
Comment 5 Roman Eisele 2012-09-06 12:24:08 UTC
Hello Fabien,

thank you for your bug report! This is very probably the same problem as bug 52022 -- which, I hope, will get fixed soon. Therefore I mark this issue as a duplicate of bug 52022.

*** This bug has been marked as a duplicate of bug 52022 ***