Bug Hunting Session
Bug 54620 - Writer EDITING: CRASH when merging cells in table [backtrace with symbols attached]
Summary: Writer EDITING: CRASH when merging cells in table [backtrace with symbols att...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: David Tardon
URL:
Whiteboard: target:3.7.0 target:3.6.2
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-09-07 05:16 UTC by sasha.libreoffice
Modified: 2012-09-22 20:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test case for reproducing crash when merging cells of table (92.20 KB, application/vnd.oasis.opendocument.text)
2012-09-07 05:16 UTC, sasha.libreoffice
Details
backtrace with symbols produced in 3.6.1 on Fedora 64 bit (23.64 KB, text/plain)
2012-09-07 05:17 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-09-07 05:16:05 UTC
Created attachment 66760 [details]
test case for reproducing crash when merging cells of table

Writer crashes during merging of cells in table

Steps to reproduce:
0. Open first attachment with Writer
1. Select any two cells in table
2. Merge them using button on toolbar "Table"

Crash reproduced in 3.6.0 on Windows XP 32 bit and in 3.6.1 on Fedora 64 bit, both downloaded rpm and self-compiled

It is regression, because in 3.5.5 not reproducible
Comment 1 sasha.libreoffice 2012-09-07 05:17:49 UTC
Created attachment 66761 [details]
backtrace with symbols produced in 3.6.1 on Fedora 64 bit
Comment 2 David Tardon 2012-09-07 08:01:46 UTC
to use a vector iterator after insert is not a good idea...
Comment 3 sasha.libreoffice 2012-09-07 08:07:56 UTC
Thanks for fixing this bug
Comment 4 Roman Eisele 2012-09-07 10:08:36 UTC
Added "target:3.7.0", right? (Fix has been pushed to master with
http://cgit.freedesktop.org/libreoffice/core/commit/?id=06ae26b5676c29c4d1cc9c65f5bbaede9483a21d)
Comment 5 David Tardon 2012-09-07 10:50:57 UTC
(In reply to comment #4)
> Added "target:3.7.0", right?

Right. It seems the bot went to sleep....
Comment 6 Not Assigned 2012-09-07 12:46:30 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=032b29619484a2a4ade0600cd978df86d5d522a5&g=libreoffice-3-6

fdo#54620 do not use vector iterator after insert


It will be available in LibreOffice 3.6.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Jean-Baptiste Faure 2012-09-22 20:30:19 UTC
Verified in LO 3.6.2.1 under Linux / Ubuntu 12.04 x86_64