Bug 54636 - On OS X, text below progress bar in splash screen is cut off
Summary: On OS X, text below progress bar in splash screen is cut off
Status: RESOLVED DUPLICATE of bug 52268
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: Other Mac OS X (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-07 12:40 UTC by Randall Wood
Modified: 2012-09-26 14:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screen capture showing truncated text at bottom of window (92.53 KB, image/png)
2012-09-07 12:40 UTC, Randall Wood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Randall Wood 2012-09-07 12:40:31 UTC
Created attachment 66787 [details]
Screen capture showing truncated text at bottom of window

This only seems to be an issue during first use after clean install or an upgrade.

Attached image shows issue.

To reproduce this delete ~/Library/Application\ Support/LibreOffice before starting LibreOffice.
Comment 1 Roman Eisele 2012-09-07 13:59:11 UTC
Thank you very much for your bug report!

REPRODUCIBLE on Mac OS X 10.6.8 (Intel) with
* LibreOffice 3.6.0.4
* LibreOffice 3.6.1.2
* LOdev 3.7.0.0.alpha0+ (Build ID: 5ca197c; pull time: 2012-09-06 07:07:33)

(In reply to comment #0)
> This only seems to be an issue during first use after clean install or an
> upgrade.

Yes, but this is true just because only after a clean install all these messages are printed at the bottom of the splash screen (on an ordinary application startup, no messages are printed there).

> To reproduce this delete ~/Library/Application\ Support/LibreOffice before
> starting LibreOffice.

... or better, just rename it; to make LibreOffice display all these messages again.
Comment 2 Roman Eisele 2012-09-07 14:01:58 UTC
@Astron, Thorsten Behrens:

Hello Astron, hello Thorsten,

here is yet another cosmetic issue with the new splash screen on Mac OS X. It is minor, but annoying, because it makes LibreOffice 3.6 look a bit "fragile" or "unfinished" on Mac OS X. Please take a look at it; it is a minor issue, of course, but should also be rather easy to fix; of course, this may involve changing the font size used for these messages.

Thank you very much!
Comment 3 Stefan Knorr (astron) 2012-09-08 19:58:02 UTC
Is this a dupe of bug 52268 or is it a valid new bug?
(I am asking because I am not completely sure if there is different code involved or not. I. e., the splash screens for Windows and Linux use different code.)
Comment 4 Roman Eisele 2012-09-09 07:35:32 UTC
(In reply to comment #3)
> Is this a dupe of bug 52268 or is it a valid new bug?
> (I am asking because I am not completely sure if there is different code
> involved or not. I. e., the splash screens for Windows and Linux use different
> code.)

Oh, thank you for the hint! (Why did I miss bug 52268?)

Yes, on the visual level, this IS a dupe of bug 52268 -- both on Win and on Mac OS X, the messages are displayed in the same (wrong) way. But I don’t know about the code, so someone else needs to judge this ...
Comment 5 Roman Eisele 2012-09-26 14:05:38 UTC
Marking as duplicate of bug 52268 for now, because at least at the surface it *is* the same bug.

*** This bug has been marked as a duplicate of bug 52268 ***