Download it now!
Bug 54719 - Crash when deleting a row in a sheet with conditional formatting
Summary: Crash when deleting a row in a sheet with conditional formatting
Status: RESOLVED DUPLICATE of bug 54621
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-09-10 09:38 UTC by Jean-Baptiste Faure
Modified: 2012-09-10 21:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc which crash LO (82.39 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-09-10 09:38 UTC, Jean-Baptiste Faure
Details
crash log on file reload (15.17 KB, text/plain)
2012-09-10 09:39 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2012-09-10 09:38:29 UTC
Created attachment 66910 [details]
bugdoc which crash LO

Step to reproduce:
- open the attached bugdoc
- on the sheet "Utilisateurs" select a row and click the button "delete row"
==> Crash

No crash if I remove all conditional formatting.

I do not know if it is the same problem, but when I was preparing this bugdoc, I removed the column "Tag" on the second sheet. Do not save but choose File > Reload and accept to cancel all changes 
==> crash with the attached crash log in the terminal.

Tested on LO 3.6.1.2 (Build ID: e29a214) under Ubuntu 12.04 x86_64 with gnome-shell.

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2012-09-10 09:39:17 UTC
Created attachment 66911 [details]
crash log on file reload
Comment 2 Jean-Baptiste Faure 2012-09-10 09:41:54 UTC
Hi Markus,

I am sorry, but think this one is for you.

Same crash with LO 3.6.2.0+ (Build ID: bb1511c)

Best regards. JBF
Comment 3 Rainer Bielefeld Retired 2012-09-10 15:05:02 UTC
NOT reproducible with "LibreOffice 3.6.1.2  German UI/ German Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit) (brand new user profile)
Comment 4 pierre-yves samyn 2012-09-10 16:40:45 UTC
Hello

I reproduce with Version 3.6.1.2 (Build ID: e29a214) & Windows 7 64bits

(new profile)

I do NOT reproduce if I delete every conditionnal formatting before deleting a row

Regards
Pierre-Yves
Comment 5 Markus Mohrhard 2012-09-10 21:15:45 UTC
Looking at the backtraces of the crashes these two are duplicates.

*** This bug has been marked as a duplicate of bug 54621 ***