Download it now!
Bug 54733 - EDITING: CRASH when deleting cell content (of sheet with conditional formatting?)
Summary: EDITING: CRASH when deleting cell content (of sheet with conditional formatti...
Status: RESOLVED DUPLICATE of bug 54498
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta3
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-09-10 13:46 UTC by th
Modified: 2012-09-16 21:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
LO calc file to test delete behavior as described (201.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-09-10 13:46 UTC, th
Details

Note You need to log in before you can comment on or make changes to this bug.
Description th 2012-09-10 13:46:52 UTC
Created attachment 66930 [details]
LO calc file to test delete behavior as described

when i try to delete multiple cell content (as per attached file), LO crashes.

how to reproduce:

1. open file e36_12.ods

2. on worksheet EARN for example delete content of cells A2:I49

3. LO crashes
Comment 1 Rainer Bielefeld Retired 2012-09-10 14:42:49 UTC
[Reproducible] with  "LibreOffice 3.6.1.2  German UI/ German Locale [Build-ID:  e29a214] on German WIN7 Home Premium (64bit) 

Problem persists with new user profile.

Seems related to conditional formatting, when I have removed all conditional formatting from sheet "EARN" I can't reproduce crash any longer.

Might be related to "Bug 54621 EDITING: CRASH  in .ods documents with lots of (conditional) formatting"
Comment 2 Rainer Bielefeld Retired 2012-09-10 15:07:29 UTC
Already [Reproducible] with 
- Server Installation of  "LibreOffice 3.6.0.4  German UI/Locale [Build-ID:  932b512] on German WIN7 Home Premium (64bit) 
- Server Installation of  "LibreOffice 3.6.0.0.beta3  German UI/Locale [Build-ID: 3e2b862] on German WIN7 Home Premium (64bit)  (new Conditional Formatting dialog)
- More early versions not tested 

Still worked fine with 
- Server installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: a502549]" (tinderbox: Win-x86@6-fast, pull time 2012-05-31 07:33:55) (Old CF dialog)


@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.    (and remove others in team from CC)
Comment 3 Markus Mohrhard 2012-09-16 21:35:10 UTC

*** This bug has been marked as a duplicate of bug 54498 ***