Download it now!
Bug 54748 - EDITING: CONDITIONAL FORMATTING not included in copy-paste cell
Summary: EDITING: CONDITIONAL FORMATTING not included in copy-paste cell
Status: RESOLVED DUPLICATE of bug 56316
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0
Keywords: regression
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-09-10 19:59 UTC by m.a.riosv
Modified: 2012-11-06 02:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
From scracht, Conditional Format is not copied with the cell. (7.92 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2012-09-10 19:59 UTC, m.a.riosv
Details
Additional Sample document (27.85 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-10-15 08:28 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2012-09-10 19:59:56 UTC
Created attachment 66940 [details]
From scracht, Conditional Format is not copied with the cell.

Win7x64 LibreOffice Version 3.7.0.0.alpha0+ (Build ID: 63a4eac)

A cell copied from another with conditional formatting doesn't have the conditional formatting.

In the sample, copy B2 to C3, no conditional formatting in C3.

Works as expected in Win7x64 LibreOffice 3.5.5.3
Comment 1 Rainer Bielefeld Retired 2012-09-11 06:12:20 UTC
[Reproducible] with reporter's sample and parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 6cad15d]"  {tinderbox: @6, pull time 2012-09-03 23:08:07} on German WIN7 Home Premium (64bit)  (installation without Base)

Condition that pasted cell contains CF is that cell above cell with CF is included to copied range. Copy-Paste B1:B2 to I19(:I20) maintains CF for I20 

An Additional problem I see and what might be related, I do not know: When I open the document with 3.6.1, no style will be recognized in CF dialog for B2. May be an invalid or unrecognized Style reference is the root of the problem?



3.5.6.2 does the copy/paste without problems, pasted cell has CF as expected. 

Currently only tested with WIN?

@mariosv 
Problem of this report also reproducible in particular cases with the test file you presented on <libreoffice-qa@lists.freedesktop.org>:
Copy Paste H19 to L19 will loose CF, same for U11 to L11. Also the effect that including cell above heals the problem is the samethere.

@Spreadsheet Team:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 2 Not Assigned 2012-09-16 02:17:36 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=78e35a68b23830debc574431c18f1b7637a513c8

only delete cond formats when attributes are deleted, fdo#54748



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Rainer Bielefeld Retired 2012-10-15 08:24:16 UTC
Still [Reproducible] with  "LibreOffice 3.6.3.1” German UI/ German Locale [Build-ID: f8fce0b] on German WIN7 Home Premium (64bit) 


Worked fine until Server Installation of "LibreOffice 3.6.2.2 release”  German UI/ German Locale [Build-ID:  da8c1e6] on German WIN7 Home Premium (64bit) 

Again works fine with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 747ecb]"  {tinderbox: @16, pull time 2012-10-08 09:46:32} on German WIN7 Home Premium (64bit) with separate User Profile for Master Branch

So it seems the problem simply is that we need the fix backported to 3.6?

An additional problem is that my 3.6.3.1 does not recognize CF in reporter's sample (works fine again with mentionen Master build), so I will add a new sample for the reopen.
Comment 4 Rainer Bielefeld Retired 2012-10-15 08:28:51 UTC
Created attachment 68569 [details]
Additional Sample document

Steps how to reproduce remaining problem with 3.6.3.1:

1. Open sample document form LibO start center File dialog
2. Click Row Heading "3" to select all row
3. <control+c> for copy
4. Click A10
5. <control+v> for paste
   Expected: O10 shows blue cell borders around contents "R64"
   Actual: no conditional border

Paste Special with checked "Formats" also will not work
Comment 5 Markus Mohrhard 2012-11-05 21:37:22 UTC

*** This bug has been marked as a duplicate of bug 56316 ***
Comment 6 m.a.riosv 2012-11-06 02:55:50 UTC
This bug (54748) marked as duplicate of a posterior (56316).