Bug Hunting Session
Bug 54750 - FILEOPEN: crash when opening xlsx file
Summary: FILEOPEN: crash when opening xlsx file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.5.3 release
Hardware: Other All
: medium normal
Assignee: Muthu
URL:
Whiteboard: BSA target:3.7.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-10 20:50 UTC by Vincent
Modified: 2012-09-13 14:20 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
xlsx file which crash LibreOffice Calc (8.62 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2012-09-10 20:50 UTC, Vincent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent 2012-09-10 20:50:53 UTC
Created attachment 66944 [details]
xlsx file which crash LibreOffice Calc

Steps to reproduce:
1. try to open the attached file

Current behavior:
Calc crash

Expected behavior:
Calc should not crash

           
Browser: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0
Comment 1 Vincent 2012-09-10 21:01:18 UTC
The terminal report this error message:
terminate called after throwing an instance of 'com::sun::star::packages::zip::ZipIOException'

The first time I get the bug, I saw a windows asking me if I want to report it (I say Yes) but now I do not see this windows anymore.
Comment 2 Markus Mohrhard 2012-09-13 01:24:35 UTC

*** This bug has been marked as a duplicate of bug 54609 ***
Comment 3 Muthu 2012-09-13 14:02:50 UTC
Seems like another exception that the function can throw :(
Comment 5 Not Assigned 2012-09-13 14:20:13 UTC
Muthu Subramanian committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9748670e040e993d66eb777225772e62d0ca2b4e

fdo#54750: Handle any kind of exception (ooxml import).



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.