Bug 54774 - EDITING: CONDITIONAL FORMATTING, loading a file create with 3.5.5.3 the Manage window doesn't show the conditions right for all CF ranges.
Summary: EDITING: CONDITIONAL FORMATTING, loading a file create with 3.5.5.3 the Manag...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.0.alpha0+ Master
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-11 13:59 UTC by m.a.riosv
Modified: 2012-09-14 00:23 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
File test (22.20 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2012-09-11 13:59 UTC, m.a.riosv
Details
Test screenshot. (65.30 KB, image/jpeg)
2012-09-14 00:23 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description m.a.riosv 2012-09-11 13:59:05 UTC
Created attachment 66975 [details]
File test

Win7x64 LibreOffice Version 3.7.0.0.alpha0+ (Build ID: 63a4eac)

Opening the sample file in LibDev 3.7, the Manage window doesn't show the true condition in CF.
Seems to get the ranges in relation with the range of the actual cell in the sheet.
Comment 1 Markus Mohrhard 2012-09-12 14:20:49 UTC
Can you please add some more details to the bug report? I don't know right know what you mean.
Comment 2 m.a.riosv 2012-09-12 17:58:35 UTC
Hi Marcus,

Win7x64 Version 3.7.0.0.alpha0+ (Build ID: 7841499)

1. Goto to cell W29.
2. Menu/Format/Conditional Formatting/Manage.
   All ranges without absolute row, show row 29 in the formula of the condition.
   Also most of the CF ranges are duplicates.
3. Goto cell W6.
4. Menu/Format/Conditional Formatting/Manage.
   All ranges without absolute row, show row 6 in the formula of the condition.
   Also most of the CF ranges are duplicates.


Win7x64 Version 3.6.1.2 (Build ID: e29a214)
1. Goto to cell W29.
2. Menu/Format/Conditional Formatting/Manage.
   All ranges without absolute row, show row 29 in the formula of the condition.
   Most of the CF ranges are duplicates.
   Some ranges do not show the condition.
Comment 3 Markus Mohrhard 2012-09-13 22:00:27 UTC
Ok, so this one is not a bug.

This is one of the ugly parts of allowing relative references in conditional formats. Conditional formats are defined relative to a base cell address and every time the conditional format formula is displayed the relative part of the formula is calculated based on the original definition of the base cell address and the current cursor position.

There is no better way to show these information. Showing the original entered formula would be even more wrong because this would result in a different formula when you transform the formula string to the formula tokens.
Comment 4 m.a.riosv 2012-09-14 00:23:11 UTC
Created attachment 67127 [details]
Test screenshot.

Sorry Marcus, I think I'm missing something or sure I am in a mistake.

As you can see CF seems to work well, if you change the selection in J6, just change the CF in H6, or in any other selectable cell only changes their CF result in their row, despite having defined formulas relative which each was defined relative to its own row. I think this is different from what you are talking about.

Only pairs of cells "J8:J9" and "U8:U9" were created as array. As you can verify by selecting them and editing their CF. Which must be displayed in the window as a range, only true for the first array.
As I remember the others CF were created one by one, but can not remember if any, were copied from another.

In any case your working basis imply that the behavior of the CF formula copying from one cell to another is not the same as the formula of the corresponding cell even being equal both formulas, when they have relative addresses.

I believe it is necessary that the formulas work consistently at any place where they can be used. People can not ask themselves at each step how the formula works.
And in this case I think the formulas work as expected.

In summary, it appears that the CF work properly but the window does not show the conditions that each cell actually has. If the window does not show or can not show the actual contents of the condition, IMHO better not show it. Sometimes less is more.

Attached screenshot, with a small sample in a file from scratch. I hope it will be clear enough.

Regards.  And please try to understand my English.(In reply to comment #3)