Bug Hunting Session
Bug 54852 - FILEOPEN CRASH for particular .ods
Summary: FILEOPEN CRASH for particular .ods
Status: RESOLVED DUPLICATE of bug 54498
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.2.1 rc
Hardware: Other Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-09-13 09:45 UTC by Rainer Bielefeld Retired
Modified: 2012-09-16 12:36 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (158.97 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-09-13 09:45 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-09-13 09:45:14 UTC
Created attachment 67087 [details]
Sample Document

Found that with  "LibreOffice 3.6.2.1 rc  German UI/ German Locale [Build-ID:  ba822cc] on German WIN7 Home Premium (64bit) when I tried to prepare attached document as a sample document for a Conditional Formatting Crash bug.

Steps how to reporduce:
0. Close LibO
1. Open document by double click from WIN Explorer.
  > Crash, empty recovery dialog appears 100% reproducible

Works fine from Start Center File (LibO) Fileopen dialog.
Comment 1 Rainer Bielefeld Retired 2012-09-13 11:47:40 UTC
[Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: b45834b]"  {tinderbox: @6, pull time 2012-09-13 00:10:35} on German WIN7 Home Premium (64bit)

I lost access to a complete class of my complex spreadsheet documents with lots of (conditional) formatting.
Comment 2 pierre-yves samyn 2012-09-14 16:32:15 UTC
Hello Rainer

I reproduce the crash with Version 3.6.2.1 (Build ID: ba822cc) and Windows 7 64 bits and also XP

Unlike you, the crash also occurs from File> Open (start center)

The document opens without problem with OOo 3.2.1

Regards
Pierre-Yves
Comment 3 Rainer Bielefeld Retired 2012-09-14 16:44:12 UTC
@pierre:
Yes, I also observed this problem from File menu, the successful fileopen from menu might have been lucky chance.

@Spreadsheet Team
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf. (and remove others in team from CC)
Comment 4 Markus Mohrhard 2012-09-16 12:36:33 UTC
Changing the code in UpdateReference shows that it is just another case of the problems around ScRangeList.

*** This bug has been marked as a duplicate of bug 54498 ***